Opened 17 months ago

Closed 17 months ago

Last modified 15 months ago

#6720 closed defect (fixed)

qunit tests are packaged in the extension (Chrome and Firefox)

Reported by: hfiguiere Assignee: hfiguiere
Priority: P2 Milestone: Adblock-Plus-3.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: kzar, sebastian, tlucas Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29796577/

Description (last modified by kzar)

Environment

With adblockpluschrome master (rev 9dd0a8081209), the qunit tests are packaged in the extension archive file.

How to reproduce

  1. In an adblockpluschrome checkout, do ./build.py build -t gecko or ./build.py build -t chrome
  2. Look at the content of the respective archives: using unzip -l | grep qunit

Observed behaviour

Both qunit/tests.js and qunit/tests.js.map are packaged.

Expected behaviour

I'd expect them to not be packaged.

Analysis

In buildtools/packagerChrome.py, the create_bundles function creates the qunit/tests.js bundle for the webpack configuration, unconditionally, based on the manifest file. Then again, if bundle_tests is true, it adds another bundle in the webpack configuration, by listing the qunit/tests directory content.

Notes for testers

Check that the extension file (xpi or zip) doesn't have qunit/* in it.

Change History (7)

comment:1 Changed 17 months ago by hfiguiere

  • Cc kzar sebastian tlucas added
  • Owner set to hfiguiere

comment:2 Changed 17 months ago by hfiguiere

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 17 months ago by hfiguiere

  • Description modified (diff)

comment:4 Changed 17 months ago by kzar

  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set

Well spotted, thanks the issue is good too. I can reproduce as described.

comment:5 Changed 17 months ago by abpbot

A commit referencing this issue has landed:
Issue 6720 - Do not package the qunit test files.

comment:6 Changed 17 months ago by hfiguiere

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 15 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. The created archives no longer contain quint dir/files.

adblockpluschrome / 2093:20ad2e20df42

Note: See TracTickets for help on using tickets.