Opened 5 years ago

Closed 5 years ago

#672 closed defect (worksforme)

Adblock Plus breaks gfycat.com functionality

Reported by: joey Assignee:
Priority: P2 Milestone:
Module: Unknown Keywords:
Cc: mapx, sebastian, trev Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by trev)

Environment

Adblock Plus on Chrome, EasyList

How to reproduce

  1. Upload a file to gfycat.com
  2. It does not convert

I am the developer of Gfycat.com. Adblock Plus appears to be blocking the Ajax requests we use from our front page to convert gifs and present feedback on the progress to the user. Users with Adblock are unable to upload to our site without disabling the extension.

Please let me know how I can help resolve. I can provide the details on how our ad content is served. Surely we can find a way to accomplish ad blocking without crippling the site.


Change History (11)

comment:1 Changed 5 years ago by mapx

  • Cc mapx sebastian trev added
  • Description modified (diff)
  • Priority changed from Unknown to P2

Did you already tested in chrome, firefox ? Is it the same behaviour ?
Did you test using only easylist ? other filter lists ?
During the tests were you using other addons / extensions ? What about disabling all other and keep only ABP ?

comment:2 Changed 5 years ago by mapx

however, even disabling ABP I can see an error in the console (chrome, but also in firefox):

Error: $apply already in progress
    at Error (native)
    at g (http://assets.gfycat.com/js/vendor-0.830.js:86:201)
    at Object.e.$apply (http://assets.gfycat.com/js/vendor-0.830.js:90:307)
    at Object.j [as uploadComplete] (http://assets.gfycat.com/js/gfymain-0.830.js:1:10163)
    at Object.a.doFetchUrl (http://assets.gfycat.com/js/gfymain-0.830.js:1:9168)
    at http://assets.gfycat.com/js/vendor-0.830.js:74:180
    at http://assets.gfycat.com/js/vendor-0.830.js:144:525
    at Object.e.$eval (http://assets.gfycat.com/js/vendor-0.830.js:90:217)
    at Object.e.$apply (http://assets.gfycat.com/js/vendor-0.830.js:90:324)
    at HTMLButtonElement.<anonymous> (http://assets.gfycat.com/js/vendor-0.830.js:144:507)
initiated

comment:3 Changed 5 years ago by joey

I tried it in Chrome browser myself, with no other extensions to confirm the issue. I don't know anything else about ad block or filter lists, but we get many reports that things aren't working and the first thing we get them to do is disable ad block which usually resolves the issue.

The error message in the console is normal behaviour (angular js)

comment:4 Changed 5 years ago by mapx

click ABP icon (in chrome), options, "filter lists" tab.
what filter lists are enabled ?
what's your chrome version ?

Last edited 5 years ago by mapx (previous) (diff)

comment:5 Changed 5 years ago by joey

Whatever the defaults are. I just reinstalled the extension to look, it is called "EasyList"

Last edited 5 years ago by joey (previous) (diff)

comment:6 Changed 5 years ago by mapx

I did a test using the gif:
www.clipartbest.com/cliparts/9c4/bg7/9c4bg7Gzi.gif

now it's saying: This gif is not animated!

It's ok ?

what version is your chrome ?

comment:7 follow-up: Changed 5 years ago by mapx

I got the same result with ABP enabled / ABP disabled / the site whitelisted

All the tests ==> using only easylist

Version 1, edited 5 years ago by mapx (previous) (next) (diff)

comment:8 Changed 5 years ago by trev

  • Description modified (diff)
  • Summary changed from Gfycat developer here would like to help resolve issues caused by Adblock Plus to Adblock Plus breaks gfycat.com functionality

comment:9 in reply to: ↑ 7 Changed 5 years ago by trev

Same here, I'm unsure what the expected behavior is here. If I upload http://img3.wikia.nocookie.net/__cb20090121063838/lyricwiki/images/5/54/J_Award_Logo.gif I get "This gif is not animated!". If I upload http://slot1.images.wikia.nocookie.net/__cb1402478225/common/skins/common/images/ajax.gif it works correctly. If I try to fetch the same file from URL I get the error message mentioned in comment:2. So please answer the questions mapx asked in comment:7 above.

comment:10 Changed 5 years ago by sebastian

Also works for me with Firefox and Chrome.

Did you (joey) actually reproduced the issue? Or did you just heard about it from your users?

comment:11 Changed 5 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.