Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#6744 closed defect (fixed)

An exception thrown from the `inject.preload.js`

Reported by: zerkms Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-3.2-for-Chrome-Opera-Firefox
Module: Unknown Keywords:
Cc: sebastian, kzar, mjethani, mapx, Ross, rscott Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29807586

Description

Environment

Ubuntu xenial 16.04
Google Chrome Version 67.0.3396.79 (Official Build) (64-bit)
ABP v3.1

How to reproduce

I noticed this problem recently and I think it came together with v3.1 update.

inject.preload.js:373 GET blob:https://adblockplus.org/8759369a-6ed4-4b78-88bc-c6228c710908 0 ()

Steps to reproduce: open https://adblockplus.org/

It reproducible on basically every page.

It's not a 3rd party filters problem: reproducible with all filters disabled as well

I could successfully reproduce it on the other machine (windows). Exact steps there:

  1. Install the latest stable chrome
  2. Configure nothing go directly to the extension store and install adblock plus
  3. Open any page, eg https://stackoverflow.com
  4. See the chrome dev tools

I'm not sure what else I could do to help debugging it though

Change History (17)

comment:1 Changed 4 months ago by zerkms

@sebastian

comment:2 Changed 4 months ago by mapx

  • Cc sebastian kzar mjethani mapx added

comment:3 Changed 4 months ago by sebastian

  • Cc Ross rscott added

Ross and Rick, can either of you reproduce this? I couldn't so far.

comment:4 Changed 4 months ago by wnaumov

It seems that, having an iframe on a page might be a necessary condition in order to reproduce it. There is a related stackoverflow question: https://stackoverflow.com/questions/50849510/inject-preload-js-failing-to-load-a-file-in-chrome-from-my-dev-environment

The last quote from this question makes me think that some recent changes to iframes in chrome might have broken the adblock.

Hopefully it's of any help to you.

comment:5 Changed 4 months ago by sebastian

  • Owner set to sebastian
  • Priority changed from Unknown to P1
  • Ready set

I reproduced it with Chrome 67 (previously I tried on Chrome 66 which doesn't appear to be affected). The problem appears to be that frames with a blob: URL (created by the extension) fail to load.

comment:6 Changed 4 months ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed 4 months ago by abpbot

A commit referencing this issue has landed:
Issue 6744 - Fixed wrapper injection on Chrome 67

comment:8 Changed 4 months ago by sebastian

  • Milestone set to Adblock-Plus-3.2-for-Chrome-Opera-Firefox
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed 4 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 3.1.0.2069
Chrome 49 / 66 / 67 / Windows 7
Opera 39 / 53 / Windows 7
Firefox 51 / 60 / Windows 7

comment:10 Changed 4 months ago by gpetrioli

This bug is still present in

ABP 3.31.2
Chrome 67.0.3396.99 (64bit) / Windows 7 (ultimate)

Not sure if it is of any importance, but when i first enter a url the problems shows, if i refresh the problem is not there, and if i force reload the problem appears. So cache is involved in the problem (if it helps).

Last edited 4 months ago by gpetrioli (previous) (diff)

comment:11 Changed 4 months ago by Ross

Hi, which url are you using/entering to reproduce? I've tried this again with the latest devbuild and Chrome 67 and cannot reproduce it.

comment:12 Changed 4 months ago by Eugene

I can reproduce it by going to https://www.ssllabs.com/
AB 3.31.2
Chrome 67.0.3396.99 (Official Build) (64-bit, Windows 10)

comment:14 Changed 4 months ago by caseyw

It is still broke, please fix this.

AB 3.31.2
Version 67.0.3396.99 (Official Build) (64-bit)

comment:15 Changed 4 months ago by canwuna

From the screenshot and version numbers sent, it appears the error seen is from AdBlock and not Adblock Plus. Please contact the AdBlock support team for more insights.

comment:16 Changed 4 months ago by Tr3v0r

This is still happening for me with. When will a working version be released as the latest version in the Chrome web store is ABP 3.1

Visit ​https://www.ssllabs.com/ or https://www.splitpayments.com.au/

inject.preload.js:373 GET blob:https://www.splitpayments.com.au/792c8e23-21c4-4faf-b93d-e61257baaf27 0 ()

MacOS 10.13.5
ABP Version number 3.1
Version 67.0.3396.99 (Official Build) (64-bit)

comment:17 Changed 4 months ago by kzar

Like Ross says this issue is for Adblock Plus not AdBlock, so for any AdBlock users please go to the AdBlock team for support.

I can't reproduce this in Adblock Plus any more since Sebastian's fix, in otherwords with development build 3.1.0.2069.

Like Trevor says the current stable version of Adblock Plus is 3.1, Sebastian's fix won't be included in the stable version of Adblock Plus until the next release which will be 3.2. There's no concrete release date so far as I know, once testing has finished we can begin preperations.

Thanks for the feedback everyone, sorry for the inconvenience.

Last edited 4 months ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.