Opened on 06/12/2018 at 08:23:54 PM

Closed on 06/15/2018 at 05:08:25 PM

Last modified on 10/08/2019 at 06:05:14 PM

#6744 closed defect (fixed)

An exception thrown from the `inject.preload.js`

Reported by: zerkms Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-3.2-for-Chrome-Opera-Firefox
Module: Unknown Keywords:
Cc: sebastian, kzar, mjethani, mapx, Ross, rscott Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):



Ubuntu xenial 16.04
Google Chrome Version 67.0.3396.79 (Official Build) (64-bit)
ABP v3.1

How to reproduce

I noticed this problem recently and I think it came together with v3.1 update.

inject.preload.js:373 GET blob: 0 ()

Steps to reproduce: open

It reproducible on basically every page.

It's not a 3rd party filters problem: reproducible with all filters disabled as well

I could successfully reproduce it on the other machine (windows). Exact steps there:

  1. Install the latest stable chrome
  2. Configure nothing go directly to the extension store and install adblock plus
  3. Open any page, eg
  4. See the chrome dev tools

I'm not sure what else I could do to help debugging it though

Attachments (0)

Change History (19)

comment:1 Changed on 06/12/2018 at 08:24:51 PM by zerkms


comment:2 Changed on 06/12/2018 at 08:32:28 PM by mapx

  • Cc sebastian kzar mjethani mapx added

comment:3 Changed on 06/14/2018 at 05:43:11 PM by sebastian

  • Cc Ross rscott added

Ross and Rick, can either of you reproduce this? I couldn't so far.

comment:4 Changed on 06/14/2018 at 06:17:16 PM by wnaumov

It seems that, having an iframe on a page might be a necessary condition in order to reproduce it. There is a related stackoverflow question:

The last quote from this question makes me think that some recent changes to iframes in chrome might have broken the adblock.

Hopefully it's of any help to you.

comment:5 Changed on 06/14/2018 at 07:51:18 PM by sebastian

  • Owner set to sebastian
  • Priority changed from Unknown to P1
  • Ready set

I reproduced it with Chrome 67 (previously I tried on Chrome 66 which doesn't appear to be affected). The problem appears to be that frames with a blob: URL (created by the extension) fail to load.

comment:6 Changed on 06/14/2018 at 08:53:59 PM by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed on 06/15/2018 at 05:05:00 PM by abpbot

A commit referencing this issue has landed:
Issue 6744 - Fixed wrapper injection on Chrome 67

comment:8 Changed on 06/15/2018 at 05:08:25 PM by sebastian

  • Milestone set to Adblock-Plus-3.2-for-Chrome-Opera-Firefox
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed on 06/19/2018 at 01:13:24 PM by Ross

  • Tester changed from Unknown to Ross
  • Verified working set


Chrome 49 / 66 / 67 / Windows 7
Opera 39 / 53 / Windows 7
Firefox 51 / 60 / Windows 7

comment:10 Changed on 06/28/2018 at 08:19:15 AM by gpetrioli

This bug is still present in

ABP 3.31.2
Chrome 67.0.3396.99 (64bit) / Windows 7 (ultimate)

Not sure if it is of any importance, but when i first enter a url the problems shows, if i refresh the problem is not there, and if i force reload the problem appears. So cache is involved in the problem (if it helps).

Last edited on 06/28/2018 at 08:27:51 AM by gpetrioli

comment:11 Changed on 06/28/2018 at 10:20:05 AM by Ross

Hi, which url are you using/entering to reproduce? I've tried this again with the latest devbuild and Chrome 67 and cannot reproduce it.

comment:12 Changed on 07/01/2018 at 06:37:18 AM by Eugene

I can reproduce it by going to
AB 3.31.2
Chrome 67.0.3396.99 (Official Build) (64-bit, Windows 10)

comment:13 Changed on 07/02/2018 at 11:18:28 AM by trh88

comment:14 Changed on 07/03/2018 at 03:26:18 PM by caseyw

It is still broke, please fix this.

AB 3.31.2
Version 67.0.3396.99 (Official Build) (64-bit)

comment:15 Changed on 07/03/2018 at 04:30:06 PM by canwuna

From the screenshot and version numbers sent, it appears the error seen is from AdBlock and not Adblock Plus. Please contact the AdBlock support team for more insights.

comment:16 Changed on 07/03/2018 at 11:51:51 PM by Tr3v0r

This is still happening for me with. When will a working version be released as the latest version in the Chrome web store is ABP 3.1

Visit ​ or

inject.preload.js:373 GET blob: 0 ()

MacOS 10.13.5
ABP Version number 3.1
Version 67.0.3396.99 (Official Build) (64-bit)

comment:17 Changed on 07/04/2018 at 04:12:42 PM by kzar

Like Ross says this issue is for Adblock Plus not AdBlock, so for any AdBlock users please go to the AdBlock team for support.

I can't reproduce this in Adblock Plus any more since Sebastian's fix, in otherwords with development build

Like Trevor says the current stable version of Adblock Plus is 3.1, Sebastian's fix won't be included in the stable version of Adblock Plus until the next release which will be 3.2. There's no concrete release date so far as I know, once testing has finished we can begin preperations.

Thanks for the feedback everyone, sorry for the inconvenience.

Last edited on 07/04/2018 at 04:14:20 PM by kzar

comment:18 Changed on 05/28/2019 at 10:18:20 AM by RandyBonnette


Last edited on 10/08/2019 at 06:05:10 PM by kzar

comment:19 Changed on 06/27/2019 at 11:01:58 PM by emadgad45


Last edited on 10/08/2019 at 06:05:14 PM by kzar

Add Comment

Modify Ticket

Change Properties
as closed .
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from sebastian.
Note: See TracTickets for help on using tickets.