Opened 18 months ago

Closed 17 months ago

Last modified 17 months ago

#6746 closed defect (fixed)

Element hiding filter applied although it shouldn't

Reported by: arthur Assignee: kzar
Priority: P1 Milestone: Adblock-Plus-3.2-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: kzar, sebastian, Ross Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29808555/

Description (last modified by kzar)

Environment

  • Chrome 67.0.3396.87 (Official Build) (64-bit) or 69.0.3457.0 (Official Build) canary (64-bit)
  • ABP dev build 3.1.0.2065
  • EasyList Germany+EasyList
  • No AA

How to reproduce

  1. Go to http://notebooksbilliger.de/

Observed behaviour

No self-promotion banners (served from tpc.googlesyndication.com) appearing.

Expected behaviour

Self-promo banners should show since they are specifically whitelisted in EasyList Germany.

Notes

If you check the ABP dev panel, you'll notice ##.img_ad is still applied although whitelisted via notebooksbilliger.de#@#.img_ad in EasyList Germany. Even adding @@||notebooksbilliger.de^$elemhide doesn't help here. It seems ABP cannot recognize the hiding filter is applied on this domain, there simply is no docoment source in the ABP dev panel listed for it.

Took this issue from this comment. The actual resources seem to load correctly now.

This seems to be another regression caused by our change to update the page frame structure on browser.webNavigation.onCommitted instead of browser.webNavigation.onBeforeNavigate.

Change History (6)

comment:1 Changed 17 months ago by kzar

  • Cc Ross added
  • Description modified (diff)
  • Milestone set to Adblock-Plus-3.2-for-Chrome-Opera-Firefox
  • Priority changed from Unknown to P1
  • Ready set

comment:2 Changed 17 months ago by kzar

  • Owner set to kzar

Same problem as #6692, except this time the frames are "about:srcdoc" instead of "about:blank".

comment:3 Changed 17 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 17 months ago by abpbot

comment:5 Changed 17 months ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 17 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. The self promotion banners now show.

ABP 3.1.0.2069
Chrome 67 / 64 / 49 / Windows 7
Firefox 60 / 55 / 51 / Windows 7
Opera 52 / 45 / 38 / Windows 7

Note: See TracTickets for help on using tickets.