#6747 closed defect (duplicate)

Safari extension fails to install from adblockplus.org

Reported by: dzhang Assignee:
Priority: Unknown Milestone:
Module: Websites Keywords: safari, macos
Cc: wspee Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by dzhang)

The cause of this problem has been solved (see update 2 below) but needs someone with signing authority to generate a new package and file the update.


Environment

macOS High Sierra v10.13.5
Safari 11.1.1

How to reproduce

Open https://adblockplus.org in Safari.

Click 'Agree and Install for Safari' for the Safari extension.

Observed behaviour

The extension, adblockplussafari-1.12.4.safariextz is downloaded but is not installed.

Attempting to manually install the extension by double clicking it gives a dialog

Safari can't install this extension
An error occurred while installing the extension "Adblock Plus".

Update 1:

The code appears to be correct as I compared it with the code from the Safari Extensions gallery.

The problem seems to be that that it is not signed and/or there is no valid certificate.

I tested the process further by building a package with a certificate. This does not result in the ability to install the extension in Safari 11.1.1.

I receive the dialog asking 'Are you sure you want to install the extension "Adblock Plus"?' with cancel and trust buttons.

Choosing 'Trust' does not result in the extension being installed.

Syspolicyd seems to grant access but no installation occurs.

Update 2:

Apparently, the installation failure that I reported is due to something related to my local configuration.

Generating a new signed package was found to work fine for restoring the ability to install the Safari extension when downloaded.

Therefore, a new package should be built and replace the existing package.

I've uploaded a signed version (my personal account) for testing (https://drive.google.com/open?id=11fBr6yDw7yTfTfgYPk3ijYIOKIsxr8vU).

Expected behaviour

The extension is automatically installed after clicking the agree and install button.

Change History (15)

comment:1 Changed 17 months ago by dzhang

  • Description modified (diff)

comment:2 Changed 17 months ago by dzhang

  • Platform changed from Unknown / Cross platform to Safari

comment:3 Changed 17 months ago by dzhang

  • Description modified (diff)

comment:4 follow-up: Changed 17 months ago by wspee

  • Cc wspee added

It seems there is a problem with the build? I can't seem to unpack the extension:

$ file adblockplussafari.safariextz 
adblockplussafari.safariextz: xar archive version 1, SHA-1 checksum
$ 7z l adblockplussafari.safariextz

7-Zip [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
p7zip Version 16.02 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz (406E3),ASM,AES-NI)

Scanning the drive for archives:
1 file, 493207 bytes (482 KiB)

Listing archive: adblockplussafari.safariextz


ERROR: adblockplussafari.safariextz : Can not open the file as archive



Errors: 1

comment:5 Changed 17 months ago by wspee

Also the file seems suspiciously small, not sure if that's normal though?:

 $ du -ach adblockplus*
1.2M    adblockplusfirefox.xpi
488K    adblockplussafari.safariextz
1.7M    total
Last edited 17 months ago by wspee (previous) (diff)

comment:6 in reply to: ↑ 4 Changed 17 months ago by tlucas

Replying to wspee:

It seems there is a problem with the build? I can't seem to unpack the extension:

$ file adblockplussafari.safariextz 
adblockplussafari.safariextz: xar archive version 1, SHA-1 checksum
$ 7z l adblockplussafari.safariextz

7-Zip [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
p7zip Version 16.02 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz (406E3),ASM,AES-NI)

Scanning the drive for archives:
1 file, 493207 bytes (482 KiB)

Listing archive: adblockplussafari.safariextz


ERROR: adblockplussafari.safariextz : Can not open the file as archive



Errors: 1

I can extract the contents just fine:

$ ls
adblockplussafari-1.12.4.safariextz
tlucas@client108:~/Downloads/safari$ xar -xf adblockplussafari-1.12.4.safariextz 
tlucas@client108:~/Downloads/safari$ ls -lah
total 500K
drwxr-xr-x. 3 tlucas tlucas 4.0K Jun 13 21:23 .
drwxr-xr-x. 4 tlucas tlucas 4.0K Jun 13 21:23 ..
-rw-r--r--. 1 tlucas tlucas 482K Jun 13 21:22 adblockplussafari-1.12.4.safariextz
drwxr-xr-x. 9 tlucas tlucas 4.0K Jun 13 21:23 adblockplussafari.safariextension
tlucas@client108:~/Downloads/safari$ ls -lah adblockplussafari.safariextension/
total 216K
drwxr-xr-x.  9 tlucas tlucas 4.0K Jun 13 21:23 .
drwxr-xr-x.  3 tlucas tlucas 4.0K Jun 13 21:23 ..
-rw-r--r--.  1 tlucas tlucas  842 Jun 13 21:23 background.html
-rw-r--r--.  1 tlucas tlucas 2.1K Jun 13 21:23 background.js
-rw-r--r--.  1 tlucas tlucas 4.3K Jun 13 21:23 common.js
-rw-r--r--.  1 tlucas tlucas 2.5K Jun 13 21:23 composer.html
-rw-r--r--.  1 tlucas tlucas 2.3K Jun 13 21:23 composer.js
-rw-r--r--.  1 tlucas tlucas 3.6K Jun 13 21:23 cssProperties.js
drwxr-xr-x.  2 tlucas tlucas 4.0K Jun 13 21:23 ext
-rw-r--r--.  1 tlucas tlucas 3.9K Jun 13 21:23 firstRun.html
-rw-r--r--.  1 tlucas tlucas 3.8K Jun 13 21:23 firstRun.js
-rw-r--r--.  1 tlucas tlucas 3.9K Jun 13 21:23 i18n.js
-rw-r--r--.  1 tlucas tlucas 7.6K Jun 13 21:23 Icon.png
drwxr-xr-x.  3 tlucas tlucas 4.0K Jun 13 21:23 icons
-rw-r--r--.  1 tlucas tlucas  15K Jun 13 21:23 include.postload.js
-rw-r--r--.  1 tlucas tlucas  17K Jun 13 21:23 include.preload.js
-rw-r--r--.  1 tlucas tlucas 5.0K Jun 13 21:23 include.youtube.js
-rw-r--r--.  1 tlucas tlucas 2.4K Jun 13 21:23 Info.plist
drwxr-xr-x.  4 tlucas tlucas 4.0K Jun 13 21:23 jquery-ui
drwxr-xr-x.  3 tlucas tlucas 4.0K Jun 13 21:23 lib
drwxr-xr-x. 54 tlucas tlucas 4.0K Jun 13 21:23 _locales
-rw-r--r--.  1 tlucas tlucas  14K Jun 13 21:23 messageResponder.js
-rw-r--r--.  1 tlucas tlucas 3.3K Jun 13 21:23 notification.js
-rw-r--r--.  1 tlucas tlucas 8.8K Jun 13 21:23 options.html
-rw-r--r--.  1 tlucas tlucas  24K Jun 13 21:23 options.js
-rw-r--r--.  1 tlucas tlucas 3.6K Jun 13 21:23 popup.html
-rw-r--r--.  1 tlucas tlucas 5.0K Jun 13 21:23 popup.js
drwxr-xr-x.  2 tlucas tlucas 4.0K Jun 13 21:23 qunit
drwxr-xr-x.  4 tlucas tlucas 4.0K Jun 13 21:23 skin
-rw-r--r--.  1 tlucas tlucas 4.0K Jun 13 21:23 stats.js
-rw-r--r--.  1 tlucas tlucas 5.8K Jun 13 21:23 subscriptions.xml
-rw-r--r--.  1 tlucas tlucas  871 Jun 13 21:23 utils.js

I'm not sure, whether the size of the unpacked extension is valid though (2.0M total), but i'd assume this only reflects 10 months of (very) low maintenance.

comment:7 Changed 17 months ago by dzhang

  • Description modified (diff)

comment:8 Changed 17 months ago by dzhang

@tlucas Thanks for adding how to extract the code. The contents appear to be correct as I compared the code with the code in the extension from the Safari extensions gallery. I updated the description with my results of attempting to build a signed package with the code. I have not been able to install a signed package into Safari 11.1.1.

comment:9 Changed 17 months ago by dzhang

  • Description modified (diff)

comment:10 Changed 17 months ago by dzhang

  • Description modified (diff)

comment:11 Changed 17 months ago by dzhang

  • Description modified (diff)

comment:12 Changed 17 months ago by dzhang

  • Description modified (diff)

comment:13 Changed 17 months ago by wspee

It seems this is a duplicate of #6734 which also takes care of the re-signing and re-uploading, @dzhang can you confirm?

comment:14 Changed 17 months ago by dzhang

@wspee Indeed, this is a duplicate. Will close this one now.

comment:15 Changed 17 months ago by dzhang

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.