#6753 closed change (duplicate)

Update adblockplusui/adblockpluscore dependency to 9a652397b9af/0cf4e33d288b

Reported by: wspee Assignee:
Priority: Unknown Milestone: Adblock-Plus-3.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: greiner, sebastian, mjethani Blocked By: #6559, #6739
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Background

In #6559 FilterStorage.knownSubscriptions was changed to a Map object which necessitates #6739 to ensure the user interface stays compatible. To ensure a working extension we (Sebastian/Winsley) plan to update the abpui/abpcore dependencies together, without further ui changes (there will be a separate ui dependency update at the end of the 3.3 cycle to land the latest ui changes), right after the release of ABP 3.2.

What to change

Update adblockplusui dependecy to hg:9a652397b9af git:2fe1f424


Update adblockpluscore dependency to hg:0cf4e33d288b git:b4e73b3


Change History (8)

comment:1 Changed 15 months ago by wspee

@Sebastian/@Manish

adblockpluscore:212fe705ab82 is needed for #6739 to work but I don't know if 212fe705ab82 is sufficient in it self and/or further platform changes are needed for compatibility with the latest core, so feel free to update the core dependency/description as needed.

comment:2 Changed 15 months ago by mjethani

@wspee I would just update the dependency to 0cf4e33d288b. In #6559 I have mentioned the changes so far, I think #6739 should be sufficient.

comment:3 Changed 15 months ago by wspee

  • Description modified (diff)

@Manish Ok, thanks. I have updated the description to update the core dependency to 0cf4e33d288b instead.

comment:4 Changed 14 months ago by greiner

  • Description modified (diff)

Since we released version 3.2 of the extension yesterday I've now pushed the necessary FilterStorage.knownSubscriptions changes to adblockplusui and added the commit hashes to the ticket description accordingly.

comment:5 Changed 14 months ago by mjethani

  • Summary changed from Update adblockplusui/adblockpluscore dependency to TBA/212fe705ab82 to Update adblockplusui/adblockpluscore dependency to 9a652397b9af/0cf4e33d288b

comment:6 follow-up: Changed 14 months ago by mjethani

We might want to wait for Snippets, it's almost done.

comment:7 in reply to: ↑ 6 Changed 14 months ago by mjethani

Replying to mjethani:

We might want to wait for Snippets, it's almost done.

OK, that's covered by #6784.

comment:8 Changed 14 months ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Closed this ticket as duplicate of #6784.

Note: See TracTickets for help on using tickets.