Opened 16 months ago

Closed 14 months ago

Last modified 10 months ago

#6777 closed defect (fixed)

Clicking Subscribe link on testpages.adblockplus.org works only the second time

Reported by: oleksandr Assignee: geo
Priority: Unknown Milestone: Adblock-Plus-3.4-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: sebastian, kzar, geo Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29883571/

Description

Environment

ABP for Edge development build.

How to reproduce

  1. Go to testpages.adblockplus.org
  2. Hit the Subscribe button
  3. Observe that no popup asking about adding a subscription appeared.
  4. Go back to the testpages tab and hit the Subscribe button again.

...

Observed behaviour

Popup appears only after clicking the Subscribe button for the second time.

Expected behaviour

Popup should appear after clicking the Subscribe button for the first time.

Change History (8)

comment:1 Changed 16 months ago by kzar

  • Cc geo added

comment:2 Changed 14 months ago by geo

  • Owner set to geo

comment:3 Changed 14 months ago by geo

  • Review URL(s) modified (diff)

comment:5 Changed 14 months ago by sebastian

  • Milestone set to Adblock-Plus-3.4-for-Chrome-Opera-Firefox
  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 10 months ago by Ross

There still seems to be issues with the subscribe link. In both the current devbuild (2206) and the current release (0.9.11) the options page is opened but the subscribe popup is not displayed. It doesn't seem to matter how many times the subscribe link is clicked.

Should I create a new ticket for this?

ABP 0.9.11.2206 (Devbuild)
Edge 44.17763.1.0 / EdgeHTML 18.17763

comment:7 Changed 10 months ago by kzar

Yea, I reckon it would probably be best to open a new issue for that.

comment:8 Changed 10 months ago by Ross

I've opened a follow up for this as #7215.

Note: See TracTickets for help on using tickets.