Opened 13 months ago

Closed 8 months ago

#6778 closed defect (duplicate)

ABP for Edge fails on some test cases on testpages.adblockplus.org

Reported by: oleksandr Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, kzar, geo, hfiguiere Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Development Build of ABP for Edge

How to reproduce

  1. Go to https://testpages.adblockplus.org and navigate in different test cases.


Observed behaviour

Test cases fail for:

  • -abp-has()
  • Chained extended selectors
  • Regular expression in :-abp-contains()

Expected behaviour

Test cases at least for -abp-has() and Chained extended selectors should work.

Change History (8)

comment:1 Changed 13 months ago by kzar

  • Cc geo added

comment:2 Changed 13 months ago by sebastian

  • Cc hfiguiere added

Hubert, any idea why emulated element hiding selectors might not (fully) work on Microsoft Edge?

Ollie, did you see any error logged to the console?

comment:3 follow-up: Changed 13 months ago by sebastian

Maybe related to #6304?

comment:4 in reply to: ↑ 3 Changed 13 months ago by hfiguiere

Replying to sebastian:

Maybe related to #6304?

That would be my guess as well. We have a few case where we catch exception for Edge as they might not support that CSS feature we use.

comment:5 Changed 13 months ago by oleksandr

No, I don't see any errors in the console. And I haven't really looked into the issue any deeper, unfortunately.

comment:6 Changed 13 months ago by hfiguiere

If it is issue #6304, we catch the exception.

See lib/content/elemHideEmulation.js around line 163. There is an explicit catch to check the feature that Edge doesn't seem to have. Maybe this is the time it should be fixed.

comment:7 Changed 13 months ago by sebastian

If it's really just about #6304 (and assuming there is no low-hanging fruit replacing the :scope pseudo-class?), we might want to just accept that limitation on Microsoft Edge for now. It's not the only limitation we have there, and it seems we currently have more pressing issues to tackle on Microsoft Edge. Also chances are that Microsoft Edge will support :scope in the future.

comment:8 Changed 8 months ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #6304.

Note: See TracTickets for help on using tickets.