Opened 5 years ago

Closed 5 years ago

#678 closed defect (incomplete)

ABP extension hangs in Chrome

Reported by: FireMedic949 Assignee:
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: sebastian, trev, mapx Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Windows 7 Pro x64
Chrome 35.0.1916.155
ABP: 1.8.3
Filters: Easy List
ABP installed via group policy

How to reproduce

When opening a web page, it hangs with a message in the lower left corner of Chrome saying "Waiting for Extension Ad Block Plus". This issue began a few weeks ago presumably with the ABP update to 1.8.3.

Attachments (1)

adblockpluschrome-1.8.1.zip (660.9 KB) - added by sebastian 5 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by mapx

  • Cc sebastian trev mapx added
  • Component changed from Unknown to Platform
  • Priority changed from Unknown to P2

comment:2 Changed 5 years ago by mapx

comment:3 Changed 5 years ago by mapx

@FireMedic949, did you test a "normal" installation ?

Changed 5 years ago by sebastian

comment:4 Changed 5 years ago by sebastian

I can not reproduce any behavior I would describe as "hanging" with Adblock Plus 1.8.3 and the latest version of Google Chrome on Linux, Windows and Mac OS X.

What is the exact behavior while it hangs beside showing that message? Is Chrome or just the current page unresponsive? Or does it just stop loading the current page?

Does it hang all the time and on all pages, or only sometimes or on some pages? Do you have an URL where this is reliable reproducible?

When does the hanging kicks in? Immediately after you launched Chrome? Or when you tried to open the first page? Or in the middle of loading a page?

Does it hang forever or does Chrome resume after waiting for a while?

Does it hang when disabling Adblock Plus on the current page or when disabling EasyList in the options?

Does it also hang with the development build and/or with the previous version Adblock Plus 1.8.1​?

comment:5 Changed 5 years ago by sebastian

Some filters that might be responsible for this issue have been just removed from EasyList:
https://hg.adblockplus.org/easylist/rev/b6dde40f7a9f

Can somebody confirm that the issue is gone after updating the filters lists?

comment:6 Changed 5 years ago by FireMedic949

It would "hang" every time I opened Chrome and went to any webpage. The webpage will stay in loading status with a "Waiting on extension AdBlock Plus" notification in the lower left. I found some recent (appears to be post 1.8.3 release) forum posts with similar complaints. I'll re-enable the GPO with 1.8.3 tomorrow or friday and see if the filter change has resolved the issue. If it doesn't I'll try reverting to 1.8.1 (if possible since I think Chrome recently blocked non-app store extensions).

comment:7 Changed 5 years ago by trev

For reference, the issue with these filters is regular expressions with exponential execution time. It has been a while since the last such issue for Mozilla, their regexp engine no longer seems to be affected. Chrome's might still be however.

comment:8 Changed 5 years ago by sebastian

Yes, there are more users which experienced a similar behavior recently. However it doesn't necessarily has something to do with the 1.8.3 update. It might also be an issue with the filter list, which is updated independently. You can manually force a filter list update by going to the options and clicking "Update now". Please let me know whether that helps.

If the hanging still occurs, please install the previous version of Adblock Plus, to see if it is an issue with the new release. Therefore download and unzip adblockpluschrome-1.8.1.zip and load it as unpacked extension. This is the easiest way you can still install extensions from outside the Chrome Web Store.

comment:9 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

Users on the forum confirmed that the issue is fixed after EasyList update.

Closing as invalid, since it wasn't a bug in Adblock Plus, but a filter list issue.

Note: See TracTickets for help on using tickets.