Opened 14 months ago

Closed 3 weeks ago

#6793 closed defect (rejected)

Element hiding exception rule not working for specific case

Reported by: arthur Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: oleksandr, geo, sebastian Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 10 Pro
Edge 42.17134.1.0
ABP dev 0.9.11.2076

How to reproduce

  1. Point any domain to 127.0.0.1 in your hosts file (e.g. eyeo.com)
  2. Download the attachment and run a local server in the same directory (with python 3.x: python -m http.server with python 2.x: python -m SimpleHTTPServer)
  3. Add ##.adsbygoogle as a custom rule (or just use EasyList)
  4. Open http://eyeo.com:8000/eyeo.html
  5. Add eyeo.com#@#.adsbygoogle as a custom rule

Observed behaviour

It says "should be visible" twice. It's missing in the first rectangle.

Expected behaviour

It should say "should be visible" three times.

Notes

I thought this might be #6746 so I asked to update the dev build and the issue is still happening. Also adding @@||eyeo.com^$elemhide doesn't help.

Attachments (1)

eyeo.html (324 bytes) - added by arthur 14 months ago.

Download all attachments as: .zip

Change History (4)

Changed 14 months ago by arthur

comment:1 Changed 13 months ago by geo

I think that the problem here is that the first iframe uses srcdoc. From here it seems that it's still in development.

comment:2 Changed 10 months ago by sebastian

  • Cc sebastian added

So the first frame (using srcdoc) doesn't even show on Microsoft Edge if Adblock Plus isn't installed?

comment:3 Changed 3 weeks ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.