Opened 5 months ago

Closed 7 weeks ago

Last modified 7 weeks ago

#6795 closed defect (fixed)

Highlighter area coordinates offset by scrolling

Reported by: agiammarchi Assignee: agiammarchi
Priority: P3 Milestone:
Module: User-Interface Keywords:
Cc: Blocked By:
Blocking: #6892, #7069 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://gitlab.com/eyeo/adblockplus/adblockplusui/merge_requests/55

Change History (12)

comment:1 Changed 4 months ago by greiner

  • Owner set to agiammarchi
  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 4 months ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 months ago by greiner

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 4 months ago by greiner

  • Blocking 6892 added

comment:5 Changed 7 weeks ago by Ross

This looks fixed except for in older versions: Chrome 49 and Opera 36.

ABP 3.3.2.2175
Firefox 62 / 51 / Windows 10
Chrome 69 / 49 / Windows 10
Opera 56 / 36 / Windows 10

comment:6 Changed 7 weeks ago by agiammarchi

Ross, could you be a bit more specific about what's broken in Chrome 49 ? AFAIK event.pageX/Y are in since Chrome 45, it'd be surprising if that never worked well 'till version 49.

Any detail on how you tested this would help, thanks.

comment:7 Changed 7 weeks ago by agiammarchi

Ross, never mind, I've just managed to reproduce ... on it.

comment:8 Changed 7 weeks ago by agiammarchi

This MR addresses the issue and fixes it hopefully once for all.
https://gitlab.com/eyeo/adblockplus/abpui/adblockplusui/merge_requests/152

comment:9 Changed 7 weeks ago by agiammarchi

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed 7 weeks ago by abpbot

A commit referencing this issue has landed:
Issue 6795 - Use event layerX/Y when browsers know these

comment:11 Changed 7 weeks ago by greiner

  • Blocking 7069 added
  • Resolution set to fixed
  • Status changed from reopened to closed

comment:12 Changed 7 weeks ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 3.3.2.2176
Firefox 62 / 51 / Windows 10
Chrome 69 / 49 / Windows 10
Opera 56 / 36 / Windows 10

Note: See TracTickets for help on using tickets.