Opened 17 months ago

Closed 3 months ago

#6796 closed defect (rejected)

Ping requests not whitelisted in iframe whitelisted via $document

Reported by: arthur Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: kzar, sebastian, greiner, geo Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Windows 10
Chrome 67.0.3396.99 (Official Build) (64-bit)
ABP 3.1.0.2069 (cannot reproduce it in the 3.1 stable)
EasyList
AA

How to reproduce

  1. Open the ABP dev panel
  2. Go to https://www.forbes.com/sites/gordonkelly/2018/07/16/apple-ios-11-4-1-apps-app-store-update-upgrade-iphone-ipad-problem-ios12/ (might need to refresh once after accepting the consent message)

Observed behaviour

There are blocked ping requests like https://pagead2.googlesyndication.com/pcs/activeview?xai=SOMESTRING within the https://tpc.googlesyndication.com/safeframe/1-0-29/html/container.html?n=1 iframe.

Expected behaviour

Everything within that iframe should be whitelisted due to this rule: @@https://$document,sitekey=MFwwDQYJKoZIhvcNAQEBBQADSwAwSAJBAMLlOP3Rke738aeqtDCGp0IgSY5XBv7c+brDMmurbYvOFgakGw6sUG8fwt6VkjnOX9s9Kba1Drg2M9Bye/F3x7MCAwEAAQ

Notes

I tried to reproduce this together with Thomas on Ubuntu but there were no blocked requests like in my screenshot on Windows.

Attachments (1)

ping.PNG (258.0 KB) - added by arthur 17 months ago.

Download all attachments as: .zip

Change History (7)

Changed 17 months ago by arthur

comment:1 Changed 17 months ago by kzar

  • Cc geo added

comment:2 Changed 17 months ago by kzar

Any chance you can try and reproduce this for me Geo? I'm having trouble reproducing it myself, as the issue mentions it might require Windows.

I ask since this is possible a regression since the last release. If you can reproduce the problem, please could you try bisecting (using git bisect or similar) to figure out which commit introduced it?

comment:3 Changed 17 months ago by sebastian

IIRC, requests of the type ping are not associated with any tab (in Chrome), so that Adblock Plus wouldn't know which document caused the request and whether it is whitelisted. However, starting with Chrome 63 the request details include an initiator property we fall back to as a workaround (#6543), which I assume is why it can no longer be reproduced with Adblock Plus >=3.1.

comment:4 Changed 16 months ago by arthur

I can still reproduce it with the latest dev build (3.2.0.2101).

comment:5 Changed 16 months ago by kzar

I still can't reproduce this with Chrome 68 and unpacked equivalent of Adblock Plus 3.2.0.2101 on Debian Buster, nor on Windows 10 (1709). I don't see the https://pagead2.googlesyndication.com/pcs/activeview?xai=SOMESTRING request being made, let alone being blocked. I'm checking both in the Adblock Plus pane, and the network pane of the developer tools.

Last edited 16 months ago by kzar (previous) (diff)

comment:6 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.