#6810 closed defect (rejected)

Strange fullscreen behaviour when Fullscreen overlay hides

Reported by: vythv Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: greiner, sebastian, kzar Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

MacBook Pro 13' 2017
macOS High Sierra 10.13.6
Adblock Plus 1.12.4
Safari 11.1.2

How to reproduce

  1. Go to http://twitch.tv/
  2. Turn on fullscreen and wait until the stream overlay disappears.
  3. The screen will start to flicker.

Observed behaviour

When the stream is on fullscreen and overlay isn't hidden, it behaves normally. The problem reveals itself when the fullscreen overlay hides over time. The screen flickers, resolution changes all the time. It stops flickering as soon as I move the mouse and make the overlay appear again.
The issue looks like this: https://imgur.com/a/taPKPTd
The example is a recreation. The flickering didn't even let me record itself, because it stops flickering as soon as I start screen recording with QuickTime. It looks exactly the same though.

Expected behaviour

The screen is going to start flickering.

Attachments (1)

weird issue.mp4 (8.5 MB) - added by vythv 17 months ago.
Flickering example

Download all attachments as: .zip

Change History (5)

Changed 17 months ago by vythv

Flickering example

comment:1 Changed 17 months ago by greiner

  • Cc greiner added

Does this issue still occur after you disable the extension?

comment:2 Changed 17 months ago by vythv

No, it doesn't. It clearly is related to Adblock.

comment:3 Changed 17 months ago by greiner

  • Cc sebastian kzar added
  • Component changed from Unknown to Platform

Ok, thanks for confirming. It's unclear to me what could be causing this but it may be an OS or even hardware issue so I'm assigning this ticket to Platform for now.

comment:4 Changed 17 months ago by kzar

  • Resolution set to rejected
  • Status changed from new to closed

Thanks for reporting this, however with Apple's recently announced plan to deprecate Safari Extensions it's unlikely we'll look into this. We will be migrating users over to our new Safari App extension when it's ready instead, see #6786. Sorry, Dave.

Note: See TracTickets for help on using tickets.