Opened 5 years ago

Closed 5 years ago

#682 closed change (rejected)

GUI checkbox to en-/disable extensions.adblockplus.subscriptions_autoupdate

Reported by: Sworddragon Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Operating system: Linux 3.15
Browser: Firefox 30.0
Adblock Plus: 2.6.3

How to reproduce

  1. In the menubar open Tools -> Add-ons -> Extensions -> "Adblock Plus 2.6.3" -> Preferences

Observed behaviour

There is no option to disable automatic filter updates.

Expected behaviour

An easy to access option to disable automatic filter updates could make sense here as Firefox does also provide an option to disable automatic updates of Adblock Plus.

Change History (2)

comment:1 Changed 5 years ago by philll

  • Platform set to Firefox

comment:2 Changed 5 years ago by trev

  • Cc trev added
  • Resolution set to rejected
  • Status changed from new to closed

This is by design - you should normally never disable automatic updates. Using this preference is strongly discouraged, it exists solely for unusual setups like running Firefox from read-only media where storing changes would be impossible anyway. And somebody who created a setup like this will be able to set an option even without Adblock Plus making it too easy.

Note: See TracTickets for help on using tickets.