#6824 closed defect (duplicate)

Remove /u flag for regular expressions

Reported by: hfiguiere Assignee:
Priority: Unknown Milestone:
Module: Core Keywords:
Cc: kzar, sebastian, mjethani Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Ross Verified working: no
Review URL(s):

Description

Environment

Chrome 49 doesn't support /u in regular expression.

So we should remove it.

How to reproduce

See issue #6821

Observed behaviour

  • Errors pop on Chrome 49

Expected behaviour

No error.

What to change

  • Both lib/snippets.js and lib/common.js use /u in redundant way: remove it
  • test/browser/elemHideEmulation.js has a test for the /u flags. Ensure it is safe to use at runtime.

Change History (1)

comment:1 Changed 16 months ago by hfiguiere

  • Blocking 6821 removed
  • Resolution set to duplicate
  • Status changed from new to closed

Manish filed #6823 just before this. Marking as dupe.

Note: See TracTickets for help on using tickets.