Opened 16 months ago

Closed 16 months ago

Last modified 15 months ago

#6832 closed defect (fixed)

EasyList is not reinstalled if removed

Reported by: Ross Assignee: hfiguiere
Priority: P1 Milestone: Adblock-Plus-3.3-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: sebastian, kzar, hfiguiere Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29845576/

Description

Environment

ABP 3.2.2101
Chrome 49 / 55 / Windows 10
Firefox 61 / Windows 10

Does not occur in release 3.2

How to reproduce

  1. Install ABP.
  2. Open ABP options.
  3. In Advanced tab, remove EasyList via trashcan.
  4. Restart browser.

Observed behaviour

EasyList has not been reinstalled.

Expected behaviour

EasyList should be reinstalled.

Note

The other behaviour similar to this, where the first run page is opened with a warning and all default filter lists are re-installed if all filter lists have been removed seems to be working as expected. This only occurs when just EasyList is removed.

Change History (12)

comment:1 Changed 16 months ago by Ross

This one is perplexing me as I thought I'd already tested this and it was working fine. I thought it might be caused by the new build (.2101) but can also reproduce it now with the build where I thought this was fine (.2097).

comment:2 Changed 16 months ago by sebastian

That makes sense. The logic is to reinitialize filter lists if there is no custom filters and no subscriptions other than Acceptable Ads and the Adblock Warning Removal List. So previously removing EasyList was sufficient to trigger this condition. But now there is also the "ABP filters" list, which we might want to add to the list.

comment:3 Changed 16 months ago by sebastian

  • Cc hfiguiere added

comment:4 Changed 16 months ago by hfiguiere

  • Owner set to hfiguiere

comment:5 Changed 16 months ago by hfiguiere

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 16 months ago by hfiguiere

  • Component changed from Unknown to Adblock-Plus-for-Chromium

comment:7 Changed 16 months ago by hfiguiere

  • Component changed from Adblock-Plus-for-Chromium to Platform

comment:9 Changed 16 months ago by hfiguiere

  • Milestone set to Adblock-Plus-3.3-for-Chrome-Opera-Firefox
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:10 Changed 16 months ago by Ross

  • Ready set
  • Tester changed from Unknown to Ross

Fixed.

ABP 3.2.2102
Chrome 68 / 55 / 49 / Windows 10
Firefox 61 / 51 / Windows 10

comment:11 Changed 16 months ago by kzar

  • Priority changed from Unknown to P1

comment:12 Changed 15 months ago by Ross

  • Ready unset
  • Verified working set
Note: See TracTickets for help on using tickets.