Opened 16 months ago

Closed 3 months ago

#6839 closed defect (rejected)

Errors in console in Firefox 55, 51

Reported by: Ross Assignee:
Priority: P2 Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: sebastian, kzar, greiner Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 3.2.2102
Firefox 51 / 55 / Windows 10

Could not reproduce in Firefox 61 or any Chrome version.

How to reproduce

  1. Install ABP.
  2. Open ABP options page.
  3. Open Firefox Console (CTRL+SHIFT+J).

Observed behaviour

The following errors are displayed in the console:

port is undefined  adblockplus.js:7521
RangeError: invalid language tag: en_US  desktop-options.js:56:10

Expected behaviour

No errors to occur.

Change History (4)

comment:1 Changed 16 months ago by kzar

  • Cc greiner added
  • Priority changed from Unknown to P2
  • Ready set

I can't reproduce that "port is undefined" exception on Firefox 52.9.0 ESR, but I can reproduce the other one and some more too:

ReferenceError: reference to undefined property "tagName"[Learn More]  desktop-options.js:339:1
ReferenceError: reference to undefined property "emptyTexts"[Learn More]  desktop-options.js:77:11
RangeError: invalid language tag: en_GB  desktop-options.js:56:10
ReferenceError: reference to undefined property "url"[Learn More]  desktop-options.js:252:1
ReferenceError: reference to undefined property "url"[Learn More]  desktop-options.js:114:1

That said I can also reproduce those on Adblock Plus 3.2, so it doesn't seem to be regression since the previous release.

Apart from the exceptions in the console, does the options work OK for you on those earlier versions of Firefox?

It's not clear yet if this is a UI or Platform issue, but I'll assume the latter and triage for now...

Last edited 16 months ago by kzar (previous) (diff)

comment:2 Changed 16 months ago by greiner

I'm not sure yet either whether or not those are UI issues so I'll have to investigate further.

At least the language tag issue seems quite straight-forward because we're expecting a locale string of the format "en-GB" but - using Utils.appLocale - are getting "en_GB" back by browser.i18n.getUILanguage() which shouldn't be the case according to MDN.

Last edited 16 months ago by greiner (previous) (diff)

comment:3 Changed 16 months ago by greiner

Using Adblock Plus 3.2 with Firefox 52 ESR on Ubuntu 18.04 I didn't get any of those errors but instead:

In add-on {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}, attempting to use listener "tabs.onReplaced", which is unimplemented.  ExtensionParent.jsm:524:71
In add-on {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}, attempting to use listener "notifications.onButtonClicked", which is unimplemented.  ExtensionParent.jsm:524:71

According to MDN neither of those APIs is supported by Firefox though.

comment:4 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.