Opened 5 years ago

Closed 5 years ago

#684 closed defect (incomplete)

ABP doesn't load / crashes in Opera Developer (currently 24.0.1534.0)

Reported by: Gingerbread Man Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: externaldependency
Cc: sebastian Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Opera Developer (24.0.1534.0)
Adblock Plus 1.8.3.1202

How to reproduce

  1. Install Adblock Plus from the development builds page.
  2. Click the Go button on the right side of the notification bar to open the Extensions tab.
  3. Click the Install button next to the Adblock Plus entry, then click the Install button in the pop-up to confirm.
  4. Wait a few moments (<10 seconds on my system). The Adblock Plus icon disappears from the toolbar. Adblock Plus is disabled, and it has a Reload button to its right, suggesting it crashed.
  5. Once Adblock Plus is disabled, click the Reload button, then the Options button. This opens a new tab that says "Page crashed". After a few moments, Adblock Plus is disabled again and the Reload button reappears.
  6. On the "Page crashed" tab, you can click the "Reload this page" button. That temporarily opens the Adblock Plus Options tab. However, there are no subscriptions listed, and after a few moments, the "Page crashed" message reappears.

Observed behavior

The Adblock plus icon disappears from the toolbar.
Adblock Plus is disabled, and it has a Reload button to its right, suggesting it crashed.
Clicking the Reload button, then the Options button opens a new tab that says "Page crashed". You can click the "Reload this page" button there, and that temporarily opens the Adblock Plus Options tab. However, there are no subscriptions listed, and after a few moments, the "Page crashed" message reappears.

Expected behavior

The Adblock Plus icon should remain on the toolbar.
Adblock Plus should remain enabled.
There should be a default set of subscriptions (e.g. EasyList and Adblock Warning Removal List).
The Adblock Plus Options tab should open.

Forum thread

https://adblockplus.org/forum/viewtopic.php?f=14&t=23642

Change History (4)

comment:1 Changed 5 years ago by sebastian

  • Cc sebastian added

No matter what, the background page should not crash. So this seems like a bug in Opera. I have contacted the Opera developers and reported the issue (DNA-22173).

comment:2 Changed 5 years ago by sebastian

  • Keywords externaldependency added

comment:3 Changed 5 years ago by philll

  • Platform set to Opera

comment:4 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

I just tested the new Opera developers version 24.0.1558.3 and the issue no longer occurs.

Closing as invalid, since it was a bug in Opera, and not in Adblock Plus.

Note: See TracTickets for help on using tickets.