Opened 5 years ago

Closed 5 years ago

#685 closed defect (fixed)

Crashes IE on Fodor's

Reported by: breyed Assignee: oleksandr
Priority: P2 Milestone: Adblock-Plus-1.2-for-Internet-Explorer
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr, mapx Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by mapx)

Navigating within the Fodor's web site crashes IE. First reported in a forum topic.

  1. Enter this into the IE address bar: http://www.fodors.com/world/caribbean/bahamas/eleuthera-and-harbour-island/review-196432.html
  1. Wait about 10 seconds to ensure everything loads.
  1. Tap (or click, if using a mouse) the "Eleuthera and Harbour Island" link in the breadcrumbs (as an example - many links cause crashes).
  1. Notice the "Internet Explorer has stopped working" crash dialog. This does not occur if AdBlock Plus is disabled.

It appears that the crash only occurs if you paste the link into the address bar on a new tab. When I follow the link from the forum post, and then click the link within the Frodor's page, it doesn't crash.

Platform: Platform: IE 11.0.9600.17126; Windows 8.1 Pro x64; AdBlock Plus 1.1.0.0; 192 DPI
tested also using 1.2.636 (edit by mapx)

Exception:

Unhandled exception at 0x771EF0A3 (ntdll.dll) in iexplore.exe: 0xC0000005: Access violation writing location 0x00000014.

Stack trace:

ntdll.dllRtlpWaitOnCriticalSection() Unknown
ntdll.dllRtlpEnterCriticalSectionContended() Unknown
ntdll.dll!_RtlEnterCriticalSection@4() Unknown
urlmon.dll!6f4943b2() Unknown
[Frames below may be incorrect and/or missing, no symbols loaded for urlmon.dll]
[External Code]
LPPlugin.dll!612ea67a() Unknown
LPPlugin.dll!612ea72c() Unknown
AdblockPlus32.dll!624dc657() Unknown
AdblockPlus32.dll!624dc7dd() Unknown
[External Code]
AcLayers.dll!6ef558bf() Unknown
[External Code]

Change History (8)

comment:1 Changed 5 years ago by mapx

  • Cc oleksandr trev mapx added
  • Description modified (diff)
  • Priority changed from Unknown to P2

comment:2 Changed 5 years ago by mapx

  • Cc eric@… added

comment:3 Changed 5 years ago by trev

  • Cc trev eric@… removed

comment:4 Changed 5 years ago by oleksandr

  • Ready set

comment:5 Changed 5 years ago by oleksandr

Looks like the issue is the same as in #613. This fixes it.

comment:6 Changed 5 years ago by eric@…

  • Summary changed from Crashes IE on Frodor's to Crashes IE on Fodor's

Changed inadvertent ring-bearer reference in Summary field.

comment:7 Changed 5 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-1.2
  • Owner set to oleksandr

comment:8 Changed 5 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.