Opened 8 months ago

Closed 4 weeks ago

#6865 closed change (fixed)

Update ABP dependency to version 3.2

Reported by: diegocarloslima Assignee: diegocarloslima
Priority: P2 Milestone: Adblock-Browser-for-Android-1.5.0
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29863604/

Description (last modified by diegocarloslima)

Background

Since we're merging Firefox 59, we need to change our ABP dependency to the WebExtension one in order to keep the adblocking functionality working in Adblock Browser.

This dependency update breaks the whole communication between the extension and the Android part, because the WebExtension APIs are much more restrictive and doesn't allow us to use the Mozilla Messaging module. We'll need to adjust our code in order to make the communication possible again.

Hints for testers

Since we're shifting from the old Mozilla add-on to a WebExtension, we need to make sure that all the adblocking functionalities still work and also check for migration issues from previous versions.

Change History (8)

comment:1 Changed 8 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 8 months ago by diegocarloslima

  • Description modified (diff)

comment:3 Changed 3 months ago by abpbot

A commit referencing this issue has landed:
Issue 6865 - Update ABP dependency to version 3.2

comment:4 Changed 3 months ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 5 weeks ago by aboegler

Diego: when upgrading from 1.4.0 to the current build of 1.5.0, all ad blocking settings are lost. This includes filter lists (languages and extra), whitelisted sites, and Acceptable Ads setting.

Steps to reproduce

  1. Install version 1.4.0 from the Play Store
  2. Launch ABB, and go to three-dots menu > Settings > Ad blocking
  3. Subscribe to some filter lists under "Languages" and "More blocking options"
  4. Add a domain under "Whitelisted websites"
  5. Tap "Acceptable Ads" and deselect the checkbox
  6. Quit ABB
  7. Install version 1.5.0

Expected result

The same filter lists are enabled as prior to the upgrade, the whitelisted domain is still whitelisted, and Acceptable Ads setting is disabled.

Actual result

Only the English filter list is enabled, the whitelisted sites list is empty, and Acceptable Ads are enabled again.

comment:6 Changed 5 weeks ago by aboegler

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 4 weeks ago by diegocarloslima

The issue found was moved to #7415, since it needs a separate fix

comment:8 Changed 4 weeks ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.