#6867 closed defect (fixed)

Static generation test fails for expected_out/en/relpath

Reported by: jsonesen Assignee: jsonesen
Priority: P3 Milestone:
Module: Unknown Keywords: cms
Cc: rhowell, kvas Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29857615

Description (last modified by jsonesen)

How to reproduce

Clone CMS or update and run tox

Observed behaviour

Test fails for the rel_path expected output. This is due to the mock not working properly.

Expected behaviour

Test should pass.

Notes

Rosie reported this to me yesterday I was the one who committed the mock patch Looks like the most recent pytest update has caused a regression with the pytest mock.

What to change

Try removing the pytest-mock module and instead use the mock api

Change History (4)

comment:1 Changed 12 months ago by jsonesen

  • Description modified (diff)

comment:2 Changed 12 months ago by jsonesen

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 12 months ago by abpbot

A commit referencing this issue has landed:
Issue 6867 - Fix pytest 3.7.1 mock regression

comment:4 Changed 12 months ago by jsonesen

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.