Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#6900 closed change (fixed)

Update adblockplusui dependency to efea71d85b24

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-3.3.1-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: agiammarchi, tlucas Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by sebastian)

Background

When pushing to adblockpluschrome, the development build automation generates following output (and sends it out in a cronmail):

npm WARN eslint-config-eyeo@2.1.0 requires a peer of eslint@^5.1 but none was installed.

That is because we bumped the peer dependency in eslint-config-eyeo to eslint ^5.1 while adblockplusui is still requesting eslint ^4.16.0.

Moreover, there is no point in the first place to install (and run) ESLint when adblockplusui is pulled in as a dependency.

This has been addressed in #6899 which is the only change pulled in with this dependency update.

What to change

Update the adblockplusui dependency to efea71d85b24.

Hints for testers

The change in this dependency update has no effect on the resulting builds whatsoever.

Change History (4)

comment:2 Changed 14 months ago by sebastian

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 14 months ago by sebastian

  • Milestone set to Adblock-Plus-3.3.1-for-Chrome-Opera-Firefox

comment:4 Changed 14 months ago by sebastian

  • Description modified (diff)
Note: See TracTickets for help on using tickets.