#6914 closed defect (fixed)

Investigate exceptions reported by Microsoft Dashboard for Microsoft Edge

Reported by: oleksandr Assignee: geo
Priority: P2 Milestone: Adblock-Plus-3.4-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: sebastian, geo Blocked By:
Blocking: Platform: Edge
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29890555/

Description

Microsoft has recently added telemetry to report exceptions happening in Edge Extensions on the Developer Dashboard. The functionality is only available in Windows 10 Insider Builds for now, so we only have data from those. As of now, we have quite a few exceptions, and there are 2 exceptions that are responsible for 99% of those. I am attaching a stack trace for each of those exceptions here.

We need to investigate what is going on, and what needs to be done, so that we don't have so many exceptions reported in the Dashboard.

Attachments (2)

stackTrace2.tsv (817 bytes) - added by oleksandr 14 months ago.
stackTrace1.tsv (817 bytes) - added by oleksandr 14 months ago.

Download all attachments as: .zip

Change History (9)

Changed 14 months ago by oleksandr

Changed 14 months ago by oleksandr

comment:1 Changed 14 months ago by sebastian

  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 14 months ago by oleksandr

Most likely the cause is Access Denied error in include.preload.js on line 2114:

  let sandbox = window.frameElement &&
                window.frameElement.getAttribute("sandbox");

I have found it on WSJ website, for example here:

https://www.wsj.com/articles/maersk-tankers-turns-to-wind-power-to-cut-soaring-fuel-costs-1535641239

comment:3 Changed 14 months ago by sebastian

Would wrapping .getAttribute("sandbox") in a try/catch block silence that error?

comment:4 Changed 13 months ago by geo

  • Owner set to geo

comment:5 Changed 13 months ago by geo

  • Review URL(s) modified (diff)

comment:7 Changed 13 months ago by sebastian

  • Milestone set to Adblock-Plus-3.4-for-Chrome-Opera-Firefox
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.