Opened 15 months ago

Closed 3 months ago

#6925 closed change (rejected)

Remove selector-no-qualifying-type stylelint rule

Reported by: greiner Assignee:
Priority: Unknown Milestone:
Module: Automation Keywords: closed-in-favor-of-gitlab
Cc: ire, juliandoucette, agiammarchi, saroyanm Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

stylelint-config-eyeo includes the rule

"selector-no-qualifying-type": [true, {"ignore": ["attribute"]}]

However, this rule causes various issues throughout adblockplusui and likely also other eyeo repositories which is why it may not be appropriate for inclusion in stylelint-config-eyeo.

Also note that we did discuss adapting our code to this rule but had to settle on not doing so since it would require further changes beyond those and may introduce regressions (see discussion).

What to change

Remove "selector-no-qualifying-type" rule from stylelint-config-eyeo.

Change History (1)

comment:1 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.