Opened 3 months ago

Closed 3 months ago

Last modified 8 weeks ago

#6938 closed defect (fixed)

The hide-if-contains-and-matches-style snippet does not work on Firefox

Reported by: Ross Assignee: mjethani
Priority: P3 Milestone:
Module: Core Keywords: circumvention
Cc: sebastian, mjethani, amrmak Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29891655/

Description (last modified by mjethani)

Environment

ABP 3.3.1.2125
Firefox 61 / 55 / Windows 10

How to reproduce

  1. Add the snippet and apply it to the example in #6919.

Observed behaviour

The snippet appears to have no effect in Firefox. It works in Chrome.

Expected behaviour

The snippet to work as described in #6919.

Additional notes

The fourth and fifth parameters of the snippet in particular do not match anything, because the snippet uses the cssText property which is always blank on Firefox due to Firefox bug #137687 (see discussion about Chrome vs. Firefox).

Hints for testers

The hide-if-contains-and-matches-style snippet should work exactly as described in #6919, but on both Chrome and Firefox.

Change History (9)

comment:1 Changed 3 months ago by mjethani

  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 3 months ago by mjethani

  • Sensitive unset

comment:3 Changed 3 months ago by hfiguiere

a 17 year old Firefox bug...

comment:4 Changed 3 months ago by mjethani

Yeah, it's not exactly a "bug", because it's the expected behavior now. It was a bit of oversight on my part not to take this into account when I wrote the snippet. Nevertheless, we can work around it and develop a more standards-compliant version of the snippet in the future.

comment:5 Changed 3 months ago by abpbot

comment:6 Changed 3 months ago by mjethani

  • Owner set to mjethani
  • Review URL(s) modified (diff)

comment:7 Changed 3 months ago by mjethani

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 2 months ago by abpbot

comment:9 Changed 8 weeks ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Snippet now works on Firefox, still works in Chrome/Opera.

ABP 3.3.2.2175
Firefox 62 / 51 / Windows 10
Chrome 69 / 49 / Windows 10
Opera 56 / 36 / Windows 10

Note: See TracTickets for help on using tickets.