#6958 closed change (fixed)

Lower minSdk required for -settings module

Reported by: asmirnov Assignee:
Priority: P3 Milestone:
Module: Libadblockplus-Android Keywords:
Cc: sergz, diegocarloslima, jwangenheim Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29883555/

Description

Background

Each libadblockplus-android module has it's own limitations for android min sdk version.
For -settings module we have 21 currently:
https://github.com/adblockplus/libadblockplus-android/blob/master/adblock-android-settings/build.gradle#L9
Since it's not actually limited by 21 and since some partners can desire lower limitation we can lower it to 16 at least.

What to change

min sdk version in build.gradle and AndroidManifest.xml

Change History (4)

comment:1 Changed 13 months ago by asmirnov

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 13 months ago by abpbot

A commit referencing this issue has landed:
Issue 6958 - Lower minSdk required for -settings module

comment:4 Changed 13 months ago by asmirnov

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.