#6961 closed defect (rejected)

Rule list compilation failed: too many rules in JSON array

Reported by: damian Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

MacOS 10.13.6

Safari 12.0 (13606.2.11)

Adblock Plus 1.12.5

Enabled filter lists:
Adblock Warning Removal List
EasyList
Fanboy's Annoyance List
Adware filters
I don't care about cookies
Malware Domains
Prebake - Filter Obtrusive Cookie Notices
Spam404

How to reproduce

  1. Open Safari.
  1. Go to random website (I have not yet identified which websites trigger this bug, but it happened multiple times, within minutes of updating to the latest version of Safari).

Observed behaviour

The following error message is displayed, in a pop-up box:

AdBlock Plus

rule list compilation failed: too many rules in JSON array

Expected behaviour

No error message will be displayed.

Change History (3)

comment:1 Changed 12 months ago by gr

I'm seeing this same behavior with:

macOS 10.12.6 (16G1510)
Safari 12.0 (12606.2.11)
Adblock Plus 1.12.5

Enabled filter lists:
EasyList

There's some additional weirdness too, including some (no clue if "all") ads blocked, but no count displayed in the ABP extension icon (to the left of the address field). I tried to describe what I'm seeing in more detail than (I think?) belongs in this forum here: https://adblockplus.org/forum/viewtopic.php?f=18&t=59484

Version 0, edited 12 months ago by gr (next)

comment:2 Changed 12 months ago by greiner

  • Cc sebastian added

comment:3 Changed 12 months ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

This happened because on Safari 12, Adblock Plus is using Content Blockers no matter what, since the old blocking mechanism is no longer supported there. However, the number of rules you can have with Content Blockers is limited, and that limit seems to be exceeded here. Moreover, notice that Adblock Plus 1.12.5 is outdated, and users should migrate to Adblock Plus 2.0.

Note: See TracTickets for help on using tickets.