Opened 13 months ago

Closed 13 days ago

Last modified 13 days ago

#6979 closed change (rejected)

Don't force the use of the Safari's native Content Blocking with Safari 12

Reported by: Just4Dev Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

With Safari 12, Adblock Plus force the use of the Safari's native Content Blocking. Users can't disable this to use the fallback content blocker which perfectly works with Safari 12 (I downloaded an older version of ABP where I did disabled the Safari's native Content Blocking and ads are blocked).

How to reproduce

  1. Click ABP icon
  2. Go to General
  3. Try to disable "Use Safari's native Content Blocking (experimental)" (checkbox disabled)

What to change

The new ABP app from the Mac App Store is missing a lot of important features (custom lists, ...) the use of the old extension (from the Safari Extension Gallery) is still the best way to use ABP, but the Safari's native Content Blocking is limited by the number of rules.
Because of that some ads are not blocked (like for example ads before a YouTube videos).
What I want is to be able to disable to use of the Safari's native Content Blocking.

Environment

Adblock Plus version: 1.12.5
Safari version: 12.0
macOS version: 10.12.6 (macOS Sierra)

Attachments (1)

Screen Shot 2018-09-23 at 15.00.34.png (23.3 KB) - added by Just4Dev 13 months ago.

Download all attachments as: .zip

Change History (4)

Changed 13 months ago by Just4Dev

comment:1 Changed 13 days ago by greiner

  • Component changed from Unknown to Platform

comment:2 Changed 13 days ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

comment:3 Changed 13 days ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
Note: See TracTickets for help on using tickets.