Opened 5 years ago

Closed 5 years ago

#700 closed defect (fixed)

block element doesn't work for elements that don't have a "src", "id" or "class" attribute

Reported by: mapx Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4829486721794048

Description

Environment

ABP 1.8.3
chrome 35, 36

How to reproduce

go to http://www.crazygallery.info/
a detecting message will appear (for only 5 seconds)
let's say we want find a hiding filter (I know, not the best method for such cases)
click ABP icon
click "block element"
You can not select any element in the page

see
https://adblockplus.org/forum/viewtopic.php?f=10&t=23712

Change History (8)

comment:1 Changed 5 years ago by sebastian

  • Cc sebastian removed
  • Owner set to sebastian

comment:2 Changed 5 years ago by philll

  • Summary changed from block element ABP for chrome 1.8.3 does not work to block element ABP for chrome 1.8.3 does not work at one specific anti adblock overlay

comment:3 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Summary changed from block element ABP for chrome 1.8.3 does not work at one specific anti adblock overlay to block element doesn't work for elements that don't have a "src", "id" or "class" attribute and the dialog is covered by other elements on some websites

Currently only filters based on the elements URL, CSS classes or ID can be generated.
However, generating a filter based on the elements name and all of its attributes might be a good fallback, in case everything else fails.

Also the overlay on the given website would cover the "Block Element" dialog, because it is using a higher z-index. Instead hard-coding a z-index, a more robust approach would be to set the z-index dynamically to make sure that it is the highest in the document.

comment:4 Changed 5 years ago by mapx

is this ticket (350) also solved by your fix ?

https://issues.adblockplus.org/ticket/350

comment:5 Changed 5 years ago by sebastian

No, that is a different issue. You can't render elements outside of their frame by using z-index.

Last edited 5 years ago by sebastian (previous) (diff)

comment:6 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Summary changed from block element doesn't work for elements that don't have a "src", "id" or "class" attribute and the dialog is covered by other elements on some websites to block element doesn't work for elements that don't have a "src", "id" or "class" attribute

Moved the z-index issue to #703

comment:7 Changed 5 years ago by sebastian

  • Ready set

comment:8 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Platform set to Unknown
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.