Opened 5 years ago

Closed 5 years ago

#705 closed defect (fixed)

"Block Element" generates request blocking filters for non-HTTP URLs

Reported by: sebastian Assignee: sebastian
Priority: P4 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: mapx Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

https://hg.adblockplus.org/adblockpluschrome/rev/f5fb756ab760

Description (last modified by sebastian)

Environment

Chrome, Opera and Safari

How to reproduce

  1. Go to t-online.de with filter lists disabled
  2. Click on the ABP icon
  3. Select "Block Element"
  4. Click at the large banner at the top.

Observed behaviour

Two filters are generated, one element hiding filter matching the ID (that one if fine) and a request blocking filter for a javascript: URL.

Expected behaviour

Only request blocking filters for HTTP and HTTPS URLs should be generated. Since those are the only kind of URLs that we can actually prevent from loading, and are supported by request blocking.

Change History (5)

comment:1 Changed 5 years ago by sebastian

  • Description modified (diff)

comment:2 Changed 5 years ago by mapx

  • Cc mapx added

comment:3 Changed 5 years ago by sebastian

  • Ready set

comment:4 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Platform set to Unknown
  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.