Opened 11 months ago

Closed 3 weeks ago

#7063 closed defect (rejected)

ABP-logo and functionality vanishes on Chrome

Reported by: dbendel Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: greiner, sebastian, kzar Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Environment

Ubuntu Linux 18.04.1 LTS
Chrome Version 70.0.3538.67 (Official Build) (64-bit)
Adblock Plus 3.3.2
EasyList, ABP filters and AA subscriptions. No custom filters.

How to reproduce

Not sure, the problem happens with normal use of the browser.

Observed behaviour

The extension icon disappears. Ad blocking stops working.

The extension is still listed on chrome://extensions/ page, but the reload button must be clicked for it to start working again.

Expected behaviour

Extension icon remains. Ad blocking continues to work.

Notes

  • See the possibly related Hub issue 16813.
  • These messages show up in the background console, but it's not clear if they are related to the problem:
    Failed to load resource: net::ERR_SSL_VERSION_INTERFERENCE
    compat.js:60 Adblock Plus: Downloading URL https://easylist-downloads.adblockplus.org/antiadblockfilters.txt failed (synchronize_connection_error)
    Download address: https://easylist-downloads.adblockplus.org/antiadblockfilters.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810191530&downloadCount=4%2B
    Channel status: -1
    Server response: 0
    reportError @ compat.js:60
    compat.js:61 console.trace
    reportError @ compat.js:61
    easylist-downloads.adblockplus.org/easylist.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810200730&downloadCount=4%2B:1 Failed to load resource: net::ERR_SSL_VERSION_INTERFERENCE
    compat.js:60 Adblock Plus: Downloading URL https://easylist-downloads.adblockplus.org/easylist.txt failed (synchronize_connection_error)
    Download address: https://easylist-downloads.adblockplus.org/easylist.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810200730&downloadCount=4%2B
    Channel status: -1
    Server response: 0
    reportError @ compat.js:60
    compat.js:61 console.trace
    reportError @ compat.js:61
    easylist-downloads.adblockplus.org/abp-filters-anti-cv.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810200830&downloadCount=4%2B:1 Failed to load resource: net::ERR_SSL_VERSION_INTERFERENCE
    compat.js:60 Adblock Plus: Downloading URL https://easylist-downloads.adblockplus.org/abp-filters-anti-cv.txt failed (synchronize_connection_error)
    Download address: https://easylist-downloads.adblockplus.org/abp-filters-anti-cv.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810200830&downloadCount=4%2B
    Channel status: -1
    Server response: 0
    reportError @ compat.js:60
    compat.js:61 console.trace
    reportError @ compat.js:61
    99Error in event handler for runtime.onMessage: TypeError: Failed to construct 'URL': Invalid URL
        at port.on (<URL>)
        at Port._onMessage (<URL>)
        at ext._EventTarget._dispatch (<URL>)
        at browser.runtime.onMessage.addListener (<URL>)
        at wrapper (<URL>)
    _generated_background_page.html:1 Unchecked runtime.lastError while running browserAction.setIcon: No tab with id: 269063796.
    

Change History (10)

comment:1 follow-up: Changed 11 months ago by greiner

  • Cc greiner added

Can you elaborate a bit more on what you mean with "vanishes"? Do you see the extension listed at chrome://extensions? And if so, is it disabled or enabled?

If it's listed and enabled, it'd be great if you could also check the following:

  • Is the icon hidden in the toolbar overflow? If so, it can be unhidden by clicking on area between icons and address bar and dragging it to the left.
  • Does the options page show all filters lists and other settings as expected?
  • Did any errors occur in the extension?
    1. Go to chrome://extensions/
    2. Enable "Developer mode" in top-right corner
    3. In the Adblock Plus entry on the page click on "Details"
    4. Click on "background page" link
    5. In the new window, switch to the "Console" tab and copy any error messages you see there

comment:2 Changed 11 months ago by greiner

  • Cc sebastian kzar added

comment:3 follow-up: Changed 11 months ago by kzar

Which Operating System are you using, which version is it? If you click "Help", "About Google Chrome" could you paste me the Version string? Do you have any custom filters?

comment:4 Changed 11 months ago by kzar

  • Component changed from Unknown to Platform
  • Platform changed from Unknown / Cross platform to Chrome

comment:5 in reply to: ↑ 3 Changed 11 months ago by dbendel

I am using Linux. Ubuntu 18.04.1 LTS
Chrome: Version 70.0.3538.67 (Official Build) (64-bit)

Replying to kzar:

Which Operating System are you using, which version is it? If you click "Help", "About Google Chrome" could you paste me the Version string? Do you have any custom filters?

Version 0, edited 11 months ago by dbendel (next)

comment:6 in reply to: ↑ 1 Changed 11 months ago by dbendel

By vanishing I mean that the logo is gone and no ads were blocked anymore. The extension is listed but I have to click on "reload" to activate it again.

Point one: no it is not hidden, it is gone.
Point two: Yes, but the filter lists has not been updated ("Failed")
Point three:

Failed to load resource: net::ERR_SSL_VERSION_INTERFERENCE
compat.js:60 Adblock Plus: Downloading URL https://easylist-downloads.adblockplus.org/antiadblockfilters.txt failed (synchronize_connection_error)
Download address: https://easylist-downloads.adblockplus.org/antiadblockfilters.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810191530&downloadCount=4%2B
Channel status: -1
Server response: 0
reportError @ compat.js:60
compat.js:61 console.trace
reportError @ compat.js:61
easylist-downloads.adblockplus.org/easylist.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810200730&downloadCount=4%2B:1 Failed to load resource: net::ERR_SSL_VERSION_INTERFERENCE
compat.js:60 Adblock Plus: Downloading URL https://easylist-downloads.adblockplus.org/easylist.txt failed (synchronize_connection_error)
Download address: https://easylist-downloads.adblockplus.org/easylist.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810200730&downloadCount=4%2B
Channel status: -1
Server response: 0
reportError @ compat.js:60
compat.js:61 console.trace
reportError @ compat.js:61
easylist-downloads.adblockplus.org/abp-filters-anti-cv.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810200830&downloadCount=4%2B:1 Failed to load resource: net::ERR_SSL_VERSION_INTERFERENCE
compat.js:60 Adblock Plus: Downloading URL https://easylist-downloads.adblockplus.org/abp-filters-anti-cv.txt failed (synchronize_connection_error)
Download address: https://easylist-downloads.adblockplus.org/abp-filters-anti-cv.txt?addonName=adblockpluschrome&addonVersion=3.3.2&application=chrome&applicationVersion=70.0.3538.67&platform=chromium&platformVersion=70.0.3538.67&lastVersion=201810200830&downloadCount=4%2B
Channel status: -1
Server response: 0
reportError @ compat.js:60
compat.js:61 console.trace
reportError @ compat.js:61
99Error in event handler for runtime.onMessage: TypeError: Failed to construct 'URL': Invalid URL
    at port.on (<URL>)
    at Port._onMessage (<URL>)
    at ext._EventTarget._dispatch (<URL>)
    at browser.runtime.onMessage.addListener (<URL>)
    at wrapper (<URL>)
_generated_background_page.html:1 Unchecked runtime.lastError while running browserAction.setIcon: No tab with id: 269063796.

Replying to greiner:

Can you elaborate a bit more on what you mean with "vanishes"? Do you see the extension listed at chrome://extensions? And if so, is it disabled or enabled?

If it's listed and enabled, it'd be great if you could also check the following:

  • Is the icon hidden in the toolbar overflow? If so, it can be unhidden by clicking on area between icons and address bar and dragging it to the left.
  • Does the options page show all filters lists and other settings as expected?
  • Did any errors occur in the extension?
    1. Go to chrome://extensions/
    2. Enable "Developer mode" in top-right corner
    3. In the Adblock Plus entry on the page click on "Details"
    4. Click on "background page" link
    5. In the new window, switch to the "Console" tab and copy any error messages you see there

comment:7 follow-up: Changed 11 months ago by greiner

Thanks for the further details. Did you also see a "Adblock Plus crashed" message? In Ubuntu those might be difficult to spot since they're quite unobtrusive there.

Because based on what you're describing it sounds like, for whatever reason, the extension crashed or got killed by the browser. This may or may not be caused by the filter list download errors. So we may want to look into how we handle such continuous errors and ensure that we're not leaking memory.

I've forwarded the SSL error to Ops (see hub#16813) so that they can take a look at it from the server-side. It might be that there's some compatibility issue with the new TLS 1.3 standard which Chrome started to support with version 70.

comment:8 in reply to: ↑ 7 Changed 11 months ago by dbendel

No I did not see any crashing message.

Replying to greiner:

Thanks for the further details. Did you also see a "Adblock Plus crashed" message? In Ubuntu those might be difficult to spot since they're quite unobtrusive there.

Because based on what you're describing it sounds like, for whatever reason, the extension crashed or got killed by the browser. This may or may not be caused by the filter list download errors. So we may want to look into how we handle such continuous errors and ensure that we're not leaking memory.

I've forwarded the SSL error to Ops (see hub#16813) so that they can take a look at it from the server-side. It might be that there's some compatibility issue with the new TLS 1.3 standard which Chrome started to support with version 70.

comment:9 Changed 11 months ago by kzar

  • Description modified (diff)

By vanishing I mean that the logo is gone and no ads were blocked anymore. The extension is listed but I have to click on "reload" to activate it again.

Before you click the "reload" button, is the blue toggle button for the extension still to the left, indicating the extension is active?

comment:10 Changed 3 weeks ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.