Opened 14 months ago

Closed 14 months ago

Last modified 2 months ago

#7066 closed defect (fixed)

Homepage meta data is ignored from some subscriptions

Reported by: Ross Assignee: greiner
Priority: P2 Milestone:
Module: User-Interface Keywords:
Cc: sebastian, kzar, greiner Blocked By:
Blocking: #6936 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://gitlab.com/eyeo/adblockplus/abpui/adblockplusui/merge_requests/155

Description (last modified by greiner)

Environment

ABP 3.3.2.2175
Chrome 69 / Windows 10
Firefox 62 / Windows 10

Not a regression. Reproduced in 3.3.2.

How to reproduce

  1. Add any of the default/language filter lists.
  2. Add https://abptestpages.org/subscription-meta/homepage.txt as a custom subscription.

Observed behaviour

With the default/language filter list added, clicking its cog in the filter lists list displays the Website link in the menu.

With the custom filter listed added, the Website link does not appear in the menu, even if set in the filter list via the ! Homepage: xyz meta data comment.

Expected behaviour

The Website link to be displayed in the cog menu if the subscription includes the relevant meta data comment.

Further information

See ui#237.

Change History (9)

comment:1 Changed 14 months ago by Ross

  • Description modified (diff)

comment:2 Changed 14 months ago by greiner

  • Cc greiner added
  • Component changed from Core to User-Interface

I can reproduce this issue. But since the homepage information is correctly reflected in the subscription object that the options page receives, I'm changing the component to User-Interface.

comment:3 Changed 14 months ago by greiner

  • Owner set to greiner
  • Priority changed from Unknown to P2
  • Ready set

I can confirm that this is merely a display issue.

As expected, the menu item is being hidden the first time it's added to the UI because we don't know its homepage value in the beginning. When we do get it from the background page, however, we don't unhide it.

Therefore the homepage menu item remains hidden when adding the filter list and it's shown after reloading the page.

comment:4 Changed 14 months ago by greiner

  • Description modified (diff)

Added link to GitLab issue.

comment:5 Changed 14 months ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 14 months ago by greiner

  • Blocking 6936 added
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 8 months ago by samsun3622

Version 1, edited 8 months ago by kzar (previous) (next) (diff)

comment:9 Changed 6 months ago by ukacar

  • Verified working set
Note: See TracTickets for help on using tickets.