#7075 closed defect (invalid)

Adblock plus disrupts router's (FritzBox) admin pages

Reported by: MichaelOF Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: arthur, greiner Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Adblock Plus 3.3.1 on Firefox 60.3.0esr, lists irrelevant for issue
OpenSuse Leap 15

How to reproduce

Thought at first Firefox bug, opened this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1501832

As you may read, incorrect page display (screenshots appended to Mozilla bug report) is triggered by Adblock Plus. Although no blocked ads on page, internal router admin pages.
Page is displayed correctly as long as Adblock Plus is disabled. "Disabled on page" with active Adblock Plus is not enough.

Workaround, of course: Temporarily disable Adblock Plus when setting up router.

Change History (7)

comment:1 Changed 12 months ago by greiner

  • Cc arthur added

This sounds like a filter issue to me. Based on this documentation, there appear to be three URLs to access that Router page:

comment:2 Changed 12 months ago by greiner

  • Cc greiner added

comment:3 Changed 12 months ago by MichaelOF

@arthur

Hi,
just checked: 192.168.178.1 is not reachable, in my case. Could be the "Guest LAN" IP, separated from normal LAN.

http://fritz.box/ is the standard URL for this (and all other AVM Fritzbox routers). IP depending on setup of LAN.

http://169.254.1.1 also works.

PLUS, not sure if relevant: All URLs possible via HTTP and HTTPS.

comment:4 follow-up: Changed 12 months ago by arthur

Please manually update your filters and check if that fixes the issue.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 12 months ago by MichaelOF

Replying to arthur:

Please manually update your filters and check if that fixes the issue.

Yes, that fixes the issue, cool, THANK YOU VERY MUCH!

Any shot explanation WHY this fixes the issue? Because, as I wrote, "disable on page" did NOT solve it? Interesting...

comment:6 in reply to: ↑ 5 Changed 12 months ago by arthur

Replying to MichaelOF:

Any shot explanation WHY this fixes the issue? Because, as I wrote, "disable on page" did NOT solve it? Interesting...

Did you refresh the page after disabling ABP?

comment:7 Changed 12 months ago by arthur

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.