#7076 closed defect (worksforme)

Initial notifications are not downloaded if user quickly turns off notifications

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian, kzar, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 3.3.2.2175
Chrome 70 / Windows 10

How to reproduce

  1. Install ABP.
  2. Inspect the popup quickly and point to an active notification in the console browser.runtime.sendMessage({type: "prefs.set", key: "notificationurl", value: "http://localhost:8000/normal.json"})
  3. Wait for 60s mark.
  4. Uninstall ABP.
  5. Reinstall ABP.
  6. Point to an active notification (like Step 2).
  7. Open ABP settings and turn off notifications.
  8. Wait for 60s mark.

Observed behaviour

At Step 3, the notifications file is downloaded as expected.

At Step 8, the notifications file is not downloaded as expected.

Expected behaviour

At Step 8, the notifications file should still be downloaded, because while the user can opt-out of most notifications, they cannot opt-out of all of them.

Change History (2)

comment:1 Changed 12 months ago by Ross

I think the above is correct (the notification setting in the options page is the out-out?).

Also, unable to test this on previous release as the notification setting there is not shown until a notification has been shown.

Last edited 12 months ago by Ross (previous) (diff)

comment:2 Changed 12 months ago by Ross

  • Resolution set to worksforme
  • Status changed from new to closed

Arg, I think this is actually wrong as I tried it with a critical notification and it worked fine (still displayed) even with the setting turned off.

Note: See TracTickets for help on using tickets.