Opened 14 months ago

Closed 3 months ago

#7078 closed defect (rejected)

Block element sometimes causes console errors

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: sebastian, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 3.3.2.2176
Chrome 70 / Windows 10
Firefox 63 / Windows 10

How to reproduce

  1. Open a site like reddit, enter block element mode.
  2. Switch around other browser tabs, open new ones, close some.
  3. Go back to the block element tab and block an element/accept the filter.

Observed behaviour

Sometimes, but not always, the following errors appear in the browser consoles:

In Chrome 70 (background console):
Unchecked runtime.lastError while running browserAction.setIcon: No tab with id: 329263172.

In Firefox 63 (browser console):
NS_ERROR_NOT_INITIALIZED: ext-windows.js:16
TypeError: Argument 1 of PrecompiledScript.executeInGlobal is not an object. ExtensionContent.jsm:501:18
Error: port.onDisconnect.hasListeners is not a function content.js

-- or --

Promise resolved after context unloaded include.preload.js:864
Promise resolved after context unloaded apply.js:63
TypeError: Argument 1 of PrecompiledScript.executeInGlobal is not an object. ExtensionContent.jsm:501:18
Error: port.onDisconnect.hasListeners is not a function

Expected behaviour

Errors to not occur / be handled (if possible).

Change History (4)

comment:1 Changed 14 months ago by Ross

Block element still seems to be working fine, just the errors occur. I'm having difficulty reproducing them (more so on Chrome) so thought I would report the ones I had. I'm not sure exactly which errors are relevant.

comment:2 Changed 14 months ago by kzar

  • Component changed from Unknown to Platform
  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 14 months ago by sebastian

Duplicate of #6490?

comment:4 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.