#7083 closed defect (fixed)

Release automation fails due to translations being moved to adblockplusui

Reported by: sebastian Assignee: sebastian
Priority: P1 Milestone:
Module: Automation Keywords:
Cc: tlucas, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29931574

Description

How to reproduce / Observed behaviour

When I ran ./build.py release -t chrome -t gecko -k ~/adblockpluschrome.pem 3.4 it failed with an exception reporting that there is no _locales directory in adblockpluschrome anymore.

This happens because it needs to get the product name from the translations file in order to insert it into the automatically generated commit messages.

Expected behaviour

The product name should be picked up from adblockplusui/locale/en-US/manifest.json instead. the build.py release command should succeed.

Change History (3)

comment:1 Changed 11 months ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 11 months ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.