#7131 closed defect (fixed)

Wrong filter for regex in ABP testcase subscription filter list

Reported by: ukacar Assignee: ukacar
Priority: P2 Milestone:
Module: Unknown Keywords:
Cc: ross, kzar, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://gitlab.com/eyeo/adblockplus/testpages.adblockplus.org/merge_requests/2

Description

Filter for element hiding containing regex (last case on the page https://testpages.adblockplus.org/en/filters/element-hiding-emulation) is wrong in the ABP Testcase Subscription filter list.

Instead of the correct one that is listed on the test page under the test case:
testpages.adblockplus.org#?#div > div:-abp-contains(/ESContainsRegEx\d/))
the filterlist contains:
testpages.adblockplus.org#?#div > div:-abp-contains(/ESContainsRegEx[1-2]/)

Subscribing to the testpages filter list

How to reproduce

  1. Subscribe to the testpages filter list here: https://testpages.adblockplus.org/
  2. Navigate to the test page: https://testpages.adblockplus.org/en/filters/element-hiding-emulation
  3. Scroll to the bottom and observe that the red container with text 'ESContainsRegEx3' is not hidden (but should be)

Solution

Replace the filter with the correct one in abp-testcase-subscription.txt

Change History (12)

comment:1 Changed 11 months ago by ukacar

  • Review URL(s) modified (diff)

comment:2 Changed 11 months ago by ukacar

  • Component changed from Infrastructure to Unknown

comment:3 Changed 11 months ago by ukacar

  • Status changed from new to reviewing

comment:4 Changed 11 months ago by ukacar

  • Summary changed from Wrong filter for regex in ABP testcase subcription filter list to Wrong filter for regex in ABP testcase subscription filter list

comment:5 Changed 11 months ago by kzar

  • Cc ross kzar added

comment:6 Changed 11 months ago by kzar

  • Cc sebastian added

What do you think Ross? Also, I wonder why this wasn't caught by the test automation.

comment:7 Changed 11 months ago by kzar

(I've also filed #7133, perhaps we can avoid duplicating the filters entirely in the future.)

comment:8 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 7131 - Fixed wrong regex in ABP Testcase filterlist

comment:9 Changed 11 months ago by kzar

  • Priority changed from Unknown to P2
  • Ready set

comment:10 follow-up: Changed 11 months ago by ukacar

I think that autotests apply the filters as they are written on the testpages, instead of subscribing to the filterlist. Because only the filter in the filterlist was wrong, tests are passing with flying colors.

Since the changed was merged, can this issue be closed?

comment:11 in reply to: ↑ 10 Changed 11 months ago by kzar

Replying to ukacar:

I think that autotests apply the filters as they are written on the testpages, instead of subscribing to the filterlist. Because only the filter in the filterlist was wrong, tests are passing with flying colors.

I see, that makes sense. I guess once I've tackled #7133 this will be fine.

Since the changed was merged, can this issue be closed?

Yep, you can resolve this as fixed :)

comment:12 Changed 11 months ago by ukacar

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.