Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#714 closed defect (fixed)

ABP blocks video on pga.com

Reported by: oleksandr Assignee:
Priority: P2 Milestone: Adblock-Plus-1.2-for-Internet-Explorer
Module: Adblock-Plus-for-Internet-Explorer Keywords: ie_devbuild_1.2
Cc: Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5171847423328256/

Description (last modified by oleksandr)

Environment

ABP IE 1.2.636, IE 11, Windows 8

How to reproduce

  1. Go to http://www.pga.com/nationalchampionship/multimedia/video/matt-dobyns-nearly-repeats-hole-one-pnc

Observed behaviour

Video on a page never starts playing

Expected behaviour

Video playback should begin

Change History (6)

comment:1 Changed 5 years ago by oleksandr

  • Priority changed from Unknown to P2

comment:3 Changed 5 years ago by oleksandr

  • Description modified (diff)

comment:4 Changed 5 years ago by oleksandr

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

The issue was caused by the fact that XMLHTTPrequest was pending, when blocked. The player was waiting for that request to begin the playback. The issue is fixed by reporting the result of XMLHTTPRequest blocking.

comment:5 Changed 5 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Internet-Explorer-1.2
  • Platform set to Internet Explorer
Note: See TracTickets for help on using tickets.