#7149 closed change (duplicate)

Adjust adblockpluschrome to handle FilterStorage.subscriptions changes

Reported by: jsonesen Assignee: jsonesen
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: mjethani, hfiguiere, kzar, snoack Blocked By:
Blocking: #7054 Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29907589/

Description

Background

Issue #6856 introduced changes to the FilterStorage, adblockpluschrome/lib/subscriptionsInit.js must be adapted.

What to change

Where FilterStorage.subscriptions is iterated over use the generator call FilterStorage.subscriptions() where subscriptions.length is called use FilterStorage.subscriptionCount

Hints for testers

Ensure that accessing, and adding new lists, as well as adding user created filters is not broken

Change History (6)

comment:1 Changed 13 months ago by jsonesen

  • Milestone set to Adblock-Plus-3.4.2-for-Chrome-Opera-Firefox
  • Review URL(s) modified (diff)

Please let me know if I goofed the ticket anywhere, thanks!

comment:2 Changed 13 months ago by jsonesen

  • Blocking 7054 added
  • Cc mjethani hfiguiere kzar snoack added

comment:3 Changed 13 months ago by jsonesen

  • Summary changed from Adjust adblockplus to handle FilterStorage.subscriptions changes to Adjust adblockpluschrome to handle FilterStorage.subscriptions changes

comment:4 Changed 13 months ago by jsonesen

  • Owner changed from Sonesen to jsonesen

comment:5 Changed 13 months ago by mjethani

The module here would be Platform, but then there's no need for this ticket since the changes here are already covered in #7054 (in fact, the changes here cannot be done without a dependency update since that would result in a broken extension).

comment:6 Changed 13 months ago by kzar

  • Component changed from Core to Platform
  • Milestone Adblock-Plus-3.4.2-for-Chrome-Opera-Firefox deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this, since as Manish mentions these changes should be made as a part of #7054. He's also right that this would be a Platform (adblockpluschrome) change.

The milestone should generally be assigned when the issue is fixed, not when you first created it. Also, this is not planned to be included in the upcoming 3.4.2 release anyway.

Note: See TracTickets for help on using tickets.