Opened 9 months ago

Closed 8 months ago

#7159 closed defect (duplicate)

Filter composer not being initialized on certain pages

Reported by: greiner Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Ubuntu 18.10
Firefox 65
Adblock Plus 3.4.2

How to reproduce

  1. Go to facebook.com
  2. Reload extension
  3. Open icon popup
  4. Reload facebook.com
  5. Open icon popup

Observed behaviour

After step 3) "Block element" item is shown.
After step 5) "Block element" item is not shown.

Expected behaviour

After step 3) "Block element" item is shown.
After step 5) "Block element" item is shown.

Further information

This issue was originally reported at ui#266 and can be traced back to the same problem that we worked around in #5599.

For some reason, the ext object is still not present after the two second delay we implemented there - even after a 15 seconds delay. According to bug 1395287 the Firefox issue should've been resolved in Firefox 57 so the underlying issue may be a different one that just happens to have the same symptoms.

Change History (1)

comment:1 Changed 8 months ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket as duplicate of #5938.

Note: See TracTickets for help on using tickets.