Opened 5 years ago

Closed 5 years ago

#716 closed defect (fixed)

ABP w/Firefox 30.0 - can not move filter line items via keyboard keys

Reported by: lpat Assignee: trev
Priority: P2 Milestone: Adblock-Plus-2.6.4-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5631877410979840/

Description

Environment

Windows 7 SP 1, Firefox 30.0, Adblock Plus 2.6.3
Custom filters:
[Adblock Plus 2.0]
! Checksum: qChFsm7FbXFN/LIk/3sRcQ
! [New filter group]
http://s0.2mdn.net/*
http://content.yieldmanager.edgesuite.net/*
http://ads.clicksor.com/*
browser,navigator#menuitem(abp-menuitem)
browser,navigator#menuitem(abp-blockableitems)
browser,navigator#menuitem(id=abp-)(id$=-menuitem)

How to reproduce

  1. Attempt to move a filter line up or down via CTRL + Arrow
  2. Selected line does not move
  3. Line item may be moved up or down via mouse right click, but not via keyboard keys
  4. Process works under Firefox 29.0.1 but not 30.0 when using Firefox 29.0.1 then upgrading in place to 30.0

Observed behaviour

Filter line item does not change position when attempting to move
via CTRL+Up/Down keyboard arrow key

Expected behaviour

Filter line item should change position up/down when moving via
CTRL+Up/Down keyboard arrow key

Change History (6)

comment:1 Changed 5 years ago by lpat

Issue also fails under Firefox 30.0 under new profile and one extension (ABP 2.6.3)

comment:2 Changed 5 years ago by philll

  • Platform set to Firefox

comment:3 Changed 5 years ago by trev

  • Priority changed from Unknown to P2
  • Ready set

Confirmed issue on OS X in Firefox 30 and 33.0a1 nightly: Command+Up/Down doesn't work, it looks like Firefox is catching it now.

comment:4 Changed 5 years ago by trev

  • Owner set to trev

comment:5 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.