Opened 12 months ago

Closed 9 months ago

Last modified 9 months ago

#7163 closed change (fixed)

Create test page for basic generic hide and block filters

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: sebastian, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://gitlab.com/eyeo/adblockplus/testpages.adblockplus.org/merge_requests/9

Description (last modified by Ross)

Background

There are no test pages for testing the generic hide and block filters.

What to change

For generic hide:

  • Add a test page with two target elements.
  • Element 1 is hidden with a specific filter. Element 2 is hidden with a generic filter.
  • Add a filter to add exceptions to the generic element.
  • Add the same elements, but inside a frame, for testing frame behaviour.

For generic block:

  • Add a test page with two target images.
  • Image 1 is hidden with a specific filter ($domain=). Image 2 is hidden with a generic filter.
  • Add a filter to add exceptions to the generic image.
  • Add the same images, but inside a frame, for testing frame behaviour.

Change History (6)

comment:1 Changed 9 months ago by ubernitt

This is a duplicate of #7351, additional info may be found there

comment:2 Changed 9 months ago by Ross

  • Cc sebastian added
  • Description modified (diff)
  • Ready set

comment:3 Changed 9 months ago by Ross

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 9 months ago by abpbot

A commit referencing this issue has landed:
Issue 7163 - Create test pages for generic hide and block filters

comment:5 Changed 9 months ago by Ross

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 9 months ago by sebastian

For reference, this change broke the test automation again. I fixed it here. :(

Note: See TracTickets for help on using tickets.