Opened 15 months ago

Closed 6 months ago

#7169 closed defect (rejected)

ABP extension error message "Event pages are not currently supported"

Reported by: DavidSpector Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: kzar, mjethani, sebastian, greiner, mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mapx)

I am getting an error message from ABP on Firefox in the Extensions Debugger page (about:debugging#addons):

Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
Reading manifest: Error processing storage: An unexpected property was found in the WebExtension manifest.

I do see a manifest entry " "background": {

"persistent": true, ". Perhaps it is not needed or is in the wrong place?

Note: another user reports "I get no such warnings using the last dev build - Version number 3.4.2.2206".

Source: ABP Forum, 12/13/18

Windows 10 Home, Firefox 63.0.3 and 64.0.0, ABP 3.4.2

Attachments (1)

ABP.png (190.2 KB) - added by DavidSpector 15 months ago.
Screenshot

Download all attachments as: .zip

Change History (10)

Changed 15 months ago by DavidSpector

Screenshot

comment:1 Changed 15 months ago by mapx

  • Cc kzar mjethani sebastian greiner added

comment:2 Changed 15 months ago by mapx

Could be a duplicate of https://issues.adblockplus.org/ticket/5398
(which is reported on android ..)

Last edited 15 months ago by mapx (previous) (diff)

comment:3 Changed 15 months ago by mapx

I re-checked and I get the same warnings:

Adblock Plus development build

Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
Reading manifest: Error processing storage: An unexpected property was found in the WebExtension manifest.

Extension ID

devbuild@…

Internal UUID

c0ff5c7c-3e00-4217-83c5-8a29a309c1d6Manifest URL

I checked with uBo too: no warnings

comment:4 Changed 15 months ago by mapx

  • Description modified (diff)

comment:5 Changed 15 months ago by mapx

  • Cc mapx added

comment:6 Changed 15 months ago by kzar

  • Component changed from Unknown to Platform

comment:7 Changed 15 months ago by greiner

I can reproduce the warning message but on first glance the build looks ok. For comparison, here's the manifest.json diff between the release and development build:

@@ -1,8 +1,9 @@
 {
   "applications": {
     "gecko": {
-      "id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}", 
-      "strict_min_version": "51.0"
+      "id": "devbuild@adblockplus.org", 
+      "strict_min_version": "51.0", 
+      "update_url": "https://downloads.adblockplus.org/devbuilds/adblockplusfirefox/updates.json"
     }
   }, 
   "author": "eyeo GmbH", 
@@ -70,7 +71,7 @@
   "manifest_version": 2, 
   "minimum_chrome_version": "49.0", 
   "minimum_opera_version": "36.0", 
-  "name": "__MSG_name__", 
+  "name": "__MSG_name_devbuild__", 
   "options_ui": {
     "open_in_tab": true, 
     "page": "options.html"
@@ -90,5 +91,5 @@
   "storage": {
     "managed_schema": "managed-storage-schema.json"
   }, 
-  "version": "3.4.2"
+  "version": "3.4.2.2206"
 }

Edit: Nevermind. I was under the impression that it's not shown for the release build but it turns out it is.

Last edited 15 months ago by greiner (previous) (diff)

comment:8 Changed 15 months ago by greiner

I can reproduce this in the following environments:

Ubuntu 18.10
Firefox 64 and 65
Adblock Plus 3.0, 3.4.2 and 3.4.2.2206

Therefore this warning may have been introduced in one of the recent Firefox versions.

Version 0, edited 15 months ago by greiner (next)

comment:9 Changed 6 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.