Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#7173 closed defect (fixed)

Popup UI issues when viewing local files in Edge

Reported by: Ross Assignee: geo
Priority: Unknown Milestone: Adblock-Plus-3.4.3-for-Chrome-Opera-Firefox
Module: User-Interface Keywords:
Cc: sebastian, kzar, greiner, geo Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://gitlab.com/eyeo/adblockplus/abpui/adblockplusui/merge_requests/191

Description (last modified by kzar)

Environment

ABP 0.9.11.2206
Edge 42.17134.1.0 / EdgeHTML 17.17134

How to reproduce

  1. Download a PDF, e.g. https://www.justice.gov/file/1007271/download
  2. Open that downloaded file in Edge, so the URL should be something like file:///C:/Users/username/Desktop/untitled.pdf
  3. Open Popup UI.

Observed behaviour

The Popup UI looks broken:

  • The top right corner of the Popup UI the Options Cog has the word "Options" over the top of it.
  • The "Number of items blocked" section is also displayed, but is blank.

Expected behaviour

The Options Cog link in the Popup UI to look as it does on a normal webpage. I'm unsure if the "Number of items blocked" section should be hidden here.

Attachments (1)

7173-popui-files.png (20.3 KB) - added by Ross 6 months ago.

Download all attachments as: .zip

Change History (11)

Changed 6 months ago by Ross

comment:1 Changed 5 months ago by geo

The cause of the bug is that for local files browser.tabs.query returns an array of tabs with url undefined. Execution context doesn't matter.

comment:2 Changed 5 months ago by geo

  • Owner set to geo
  • Review URL(s) modified (diff)

comment:3 Changed 5 months ago by kzar

  • Description modified (diff)
  • Summary changed from Popup UI issues when viewing files in Edge to Popup UI issues when viewing local files in Edge

comment:4 Changed 5 months ago by abpbot

A commit referencing this issue has landed:
Issue 7173 - Fixed popup UI issues when viewing files in MS Edge

comment:6 Changed 5 months ago by sebastian

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 5 months ago by greiner

Mind adding a link to the respective GitLab issue to the ticket description?

comment:8 Changed 5 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next

comment:9 Changed 5 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 0.9.11.2216 (Devbuild)
Edge 44.17763.1.0 / EdgeHTML 18.17763

comment:10 Changed 5 months ago by sebastian

  • Milestone changed from Adblock-Plus-for-Chrome-Opera-Firefox-next to Adblock-Plus-3.4.3-for-Chrome-Opera-Firefox
Note: See TracTickets for help on using tickets.