Opened 2 months ago

Last modified 5 weeks ago

#7176 new defect

Settings page checkboxes can get stuck

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: User-Interface Keywords:
Cc: sebastian, kzar, greiner, geo Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Environment

ABP 0.9.11.2206 (Devbuild)
Edge 42.17134.1.0 / EdgeHTML 17.17134

NOT a regression compared to 0.9.11 (Release)

How to reproduce

  1. Select [ABP Icon] > [Cog].
  2. Now randomly click the checkboxes in the [Privacy and Security] section on and off.

Observed behaviour

Eventually, the checkboxes will get stuck either on or off and then become unresponsive to futher input. Their state might also not match the state of the corresponding filter subscription.

Closing and reopening the settings page fixes the issue.

Expected behaviour

Checkboxs to not get stuck / not stop responding to user input.

Further information

See also ui#296.

Change History (3)

comment:1 Changed 2 months ago by Ross

Just to note: I can only reproduce this with checkboxes that are connected to subscriptions, such as the [Privacy and Security] ones and the [Anti-circumvention] one. The others, such as in [Advanced] are fine.

comment:2 Changed 5 weeks ago by greiner

  • Platform changed from Edge to Unknown / Cross platform

I was able to reproduce this using Chrome 71.

comment:3 Changed 5 weeks ago by greiner

  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

Added link to GitLab issue.

Note: See TracTickets for help on using tickets.