Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#7217 closed defect (rejected)

Extension requests send incorrect applicationVersion on Edge — at Version 1

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: snoack, kzar, geo Blocked By:
Blocking: Platform: Edge
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Environment

ABP 0.9.11.2223 (Devbuild)
Edge 44.17763.1.0 / EdgeHTML 18.17763

NOT a regression compared to 0.9.11 (Release)

How to reproduce

  1. Install the Edge build.
  2. Uninstall the Edge build.
  3. Check the parameters of the uninstall page that appears.
  4. Also check parameters on the request for notifications.

Observed behaviour

The applicationVersion parameter is 0:

?addonName=adblockplusedge&addonVersion=0.9.11&application=edge&'''applicationVersion=0'''&platform=edgehtml&platformVersion=18.17763&lastVersion=0&downloadCount=0

Expected behaviour

The applicationVersion parameter should contain the browser version number. Which for Edge in this case should be 44.17763.1.0.

Change History (1)

comment:1 Changed 9 months ago by kzar

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Resolution set to rejected
  • Status changed from new to closed

For Edge we grab the platformVersion from the user agent string, but not the applicatinVersion. I think this is functioning correctly.

Note: See TracTickets for help on using tickets.