Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#7277 closed defect (fixed)

The number of blocked items is not displayed

Reported by: geo Assignee: geo
Priority: P1 Milestone: Adblock-Plus-3.5-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: kzar, Ross, sebastian, ukacar, rscott Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://gitlab.com/eyeo/adblockplus/adblockpluschrome/merge_requests/41/

Description (last modified by kzar)

Environment

Adblock Plus development build 3.4.3.2253
Older versions of Chrome (<= 66) and Opera (<= 54)

AND

Adblock Plus development build 0.9.13.2252
Microsoft Edge 44.17763.1.0 & 42.17134.1.0

How to reproduce

  1. Navigate to https://www.nytimes.com/

Observed behaviour

  1. Observe that the ABP icon in the browser's toolbar does not display the number of the blocked ads.
  2. Open the background page and observe errors in the console:
    Uncaught Error: Invocation of form browserAction.setBadgeText(object, function) doesn't match definition browserAction.setBadgeText(object details)
    

Expected behaviour

There should be no errors in the console of the background page, ABP icon should display the number of blocked items

Notes

Hints for testers

  • Test that the number of blocked items is now displayed on Edge and older versions of Chrome and Opera. Also, that it is continued to be displayed on Firefox and a recent version of Chrome.
  • Test that our devtools panel is still created and working properly in Chrome.

Change History (8)

comment:1 Changed 8 months ago by geo

  • Cc Ross sebastian added

comment:2 Changed 8 months ago by kzar

  • Milestone set to Adblock-Plus-3.5-for-Chrome-Opera-Firefox
  • Owner set to geo
  • Priority changed from Unknown to P1
  • Ready set

comment:3 Changed 8 months ago by geo

  • Review URL(s) modified (diff)

comment:4 Changed 8 months ago by kzar

  • Description modified (diff)
  • Platform changed from Edge to Unknown / Cross platform

Ursa has found the same problem in older versions of Chrome and Opera, I've updated this issue and marked #7297 as a duplicate of this.

comment:5 Changed 8 months ago by kzar

  • Description modified (diff)

comment:7 Changed 8 months ago by kzar

  • Cc ukacar rscott added
  • Resolution set to fixed
  • Status changed from new to closed

Heads up, the patch just landed so it should start showing up in the development build soon.

comment:8 Changed 8 months ago by ukacar

  • Verified working set
Note: See TracTickets for help on using tickets.