Opened 9 months ago

Closed 9 months ago

#7297 closed defect (duplicate)

The number of blocked items is not displayed in older versions of Chrome/Opera

Reported by: ukacar Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: kzar, sebastian Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Older versions of Chrome and Opera, ABP development build 3.4.3.2253

  • Chrome: 66 and lower, works OK from version 67 on
  • Opera: 54 and lower, works OK from version 54 on

Observations

  • this is a regression when compared to the current release 3.4.3
  • similar regression already reported on Edge here: #7277
  • might be caused by: #6490 ?

How to reproduce

With the development build installed and enabled, navigate to a page with ads (for example https://www.nytimes.com/)

Observed behaviour

  1. Observe that the ABP icon in the browser's toolbar does not display the number of the blocked ads.
  2. Open the background page and observe errors in the console:
    Uncaught Error: Invocation of form browserAction.setBadgeText(object, function) doesn't match definition browserAction.setBadgeText(object details)
    

Expected behaviour

There should be no errors in the console of the background page, ABP icon should display the number of blocked items

Change History (3)

comment:1 Changed 9 months ago by ukacar

  • Cc kzar sebastian added

comment:2 Changed 9 months ago by ukacar

  • Milestone Adblock-Plus-3.5-for-Chrome-Opera-Firefox deleted
  • Priority changed from P1 to Unknown

comment:3 Changed 9 months ago by kzar

  • Resolution set to duplicate
  • Status changed from new to closed

You're right, this is a duplicate of #7277. You provided a lot of useful information here though, so I've updated the other issue to include it. Thanks again, you helped us avoid having to fix the same problem twice.

Note: See TracTickets for help on using tickets.