Opened 4 months ago

Closed 3 months ago

Last modified 3 months ago

#7298 closed defect (rejected)

On some websites most elements are not selectable by block element

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: sebastian, kzar, ursa, greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 3.4.3.2253
Firefox 65.0.1 / 51 / Windows 10
Chrome 72.0.3626.109 / 49.0.2623.75 / Windows 10

NOT a regression from 3.4.3.

How to reproduce

  1. Navigate to https://www.bestbuy.com/?intl=nosplash
  2. Select [ABP Icon] > [Block element]

Observed behaviour

Nearly all non-image elements are unselectable.

Expected behaviour

The user to be able to select any element for blocking/hiding.

Change History (6)

comment:1 Changed 4 months ago by Ross

I noticed this when testing #5938.

comment:2 Changed 4 months ago by greiner

  • Cc greiner added
  • Component changed from Unknown to Platform

AFAIK this is by design:

Please also note that the UI doesn't provide users a way to adjust their selection (see also ui#12) so allowing them to select any element on the page would likely lead to a worse UX.

comment:3 Changed 4 months ago by Ross

Ah, I thought it might be something like that. Out of interest, do you know why I can't select most elements on the site above? I'm guessing getFiltersForElement() doesn't return any filters, but what about the elements causes that, compared to other sites?

comment:4 Changed 4 months ago by greiner

That's due to the filter @@||bestbuy.com^$elemhide in the Acceptable Ads list which disables element hiding on this particular domain.

That means that the only selectable elements are those which can be blocked without the use of element hiding filters. Some of the images on the page aren't easily recognizable as such though because they're set as a background image on DIVs or other generic elements so that's probably why you're only able to select some but not all images.

Note that selecting elements does work again as expected after disabling Acceptable Ads.

comment:5 Changed 3 months ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

As Thomas explained, everything seems to work as expected here.

comment:6 Changed 3 months ago by sathyaprabha

spam

Last edited 3 months ago by greiner (previous) (diff)
Note: See TracTickets for help on using tickets.